Project

General

Profile

Bug #6039

User cannot change her email

Added by Marilyn Weber over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority name:
High
Assignee:
-
Category name:
Membership
Target version:
Start date:
2016-09-19
Due date:
% Done:

0%

Estimated time:

Description

Cheryl Littman, Acting Dean of Institutional Effectiveness at Queens, reports:
"I am trying to change my CUNY Academic Commons account email address from to . I followed the instructions from the FAQ/Help info, changing my password as well as the account email. The screen says I'm successful, but after logging out and then back in again, the Commons Profile/Settings page still shows the email address as @mail.cuny.edu instead of @qc.cuny.edu."

I've asked her to clarify whether she was trying to chgne the password at the same time as the account email, but she says no. She has tried again with her known password and, indeed, she still gets the green notification bar that says "Your settings have been saved" I can see her in the users list (clittman) but I cannot change her address there.

I'm able to replicate this for myself. Last night I followed these instructions:
To change the email account where you receive email notifications, go to the top black navigation bar, hover over your avatar on the top right corner, and select: My Settings » General. Re-write your preferred email account in the ‘Account Email’ field, then scroll down and select “Save Changes.”
To try to change my History account (username: conduit) from to . Got the green bar, thought all was well, but my user page still shows the gmail address.

LMK what more information you need. Thanks!

StillMWeb.PNG (22.6 KB) StillMWeb.PNG Marilyn Weber, 2016-09-19 10:50 AM
clittman.PNG (15.2 KB) clittman.PNG Marilyn Weber, 2016-09-19 10:50 AM

History

#1 Updated by Boone Gorges over 5 years ago

  • Category name set to Membership
  • Status changed from New to Reporter Feedback
  • Target version set to 1.9.28

The root issue here is as follows: When you change your email address in [your profile] > Settings, CAC sends an email to the old address to verify the change. This is to make sure that no one has stolen your password, used it to impersonate you when logging in, and then changed your email address to something that doesn't belong to you. In Cheryl's case, there's probably an email in her mail.cuny.edu inbox asking her to verify the change. Please have her check.

In order to make the verification process a bit clearer, BuddyPress shows a message on the Settings panel along the lines of "You have a pending email change...." with instructions about clicking the link in the verification email. However, this message was not being displayed on the Commons because of a recent-ish change to the way that BP shows the message, a change that we didn't mirror in our custom templates. I made the change in https://github.com/cuny-academic-commons/cac/commit/f96cf400bcacffbcd74957df056061bd527ea0d7; the fix is also live on the production site.

Let me know if Cheryl is able to find the email and verify the change. I can make it manually as the administrator, but I want to be sure that there are no bugs preventing her from doing it herself.

#2 Updated by Marilyn Weber over 5 years ago

Confirmed! This case is closed. Thanks for adding that message, Boone.

#3 Updated by Boone Gorges over 5 years ago

  • Status changed from Reporter Feedback to Resolved

Excellent! Thanks, Marilyn.

Also available in: Atom PDF