Project

General

Profile

Support #10298

RSS feed to itunes problem

Added by Marilyn Weber 6 months ago. Updated 2 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
Start date:
2018-09-07
Due date:
% Done:

0%

Estimated time:

Description

Lizzie Macauley-Lewis writes:

"I am trying to create an RSS feed on the commons using the powerpress plugin for my podcastproject. While attempting to connect my RSS feed to itunes I keep getting a generic error notification.

The bluberry / powerpress FAQ suggest that the error is caused http vs. https - could that be the issue, as everything else has checked out correctly. Screen shots of the error message and the FAQs are attached.

Thank you!
Lizzie

------------------
Submitted from: https://ancientarchny.commons.gc.cuny.edu/2018/09/07/episode-1-from-the-appian-way-to-broadway/"

Itunes.JPG (95.9 KB) Itunes.JPG Marilyn Weber, 2018-09-07 03:55 PM
poss cause.JPG (119 KB) poss cause.JPG Marilyn Weber, 2018-09-07 03:55 PM
LizzieItunes.JPG (79.4 KB) LizzieItunes.JPG Marilyn Weber, 2018-09-14 10:12 PM

History

#1 Updated by Boone Gorges 6 months ago

  • Status changed from New to Reporter Feedback
  • Target version set to Not tracked

Here's a recent support thread describing similar problems: https://wordpress.org/support/topic/submitting-to-itunes-and-feed-validation-error/

It sounds like it'll be necessary to reach out to Apple to get more information on why the submission is failing. (I checked HTTPS issues as well as HEAD requests, which were both mentioned on the thread, but they're working as expected, so it must be something else.) Since Lizzie is the owner of the podcast, I'd suggest that she use the Contact Us link at the bottom of http://itunespartner.apple.com/en/podcasts/overview to state that her podcast submission is failing, and to ask for more information about the failure.

#2 Updated by Marilyn Weber 5 months ago

Lizzie received a response, which I've attached. It seems the SSL certificate is the problem?

#3 Updated by Boone Gorges 5 months ago

  • Status changed from Reporter Feedback to In Progress

Wow, that's a new one. Here's the list of compatible authorities: https://itunespartner.apple.com/en/podcasts/faq#67333021

It just so happens that GC IT is in the process of reworking the SSL infrastructure for sites like the Commons, a reworking that will involve a switch to LetsEncrypt, which is supported by Apple. I'll ping Lihua to see how that process is moving along, and to confirm that the main Commons certificate will be switched over. If so, then the current issue is one that will disappear after the migration. If not, we'll have to talk about the remaining possibilities.

#4 Updated by Boone Gorges 5 months ago

I've confirmed with IT that the infrastructure changes will include a move to LetsEncrypt for all Commons sites. Once this happens, iTunes submission should begin to work. This migration is due to happen sometime this fall. I'll try to follow up here when it does. Thanks for the patience.

#5 Updated by Boone Gorges 2 months ago

  • Status changed from In Progress to Resolved

The Commons has been moved to SSL across the board, using LE as the certificate authority. As such, Apple should now accept the RSS feed. Please feel free to reopen if this is not the case.

Also available in: Atom PDF