Project

General

Profile

Bug #10706

bp-multiple-forum-post triggers query loop on AJAX heartbeat

Added by Boone Gorges almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Forums
Target version:
Start date:
2018-11-15
Due date:
% Done:

0%

Estimated time:

Description

Previously: #6746

Something about the way that BP's AJAX heartbeat activity query works causes bp-multiple-forum-post to hit an infinite loop when looking for duplicate activity items.


Related issues

Related to CUNY Academic Commons - Bug #6746: bp-multiple-forum-post activity "backfilling" is sometimes causing infinite query loopResolved2016-11-15

History

#1 Updated by Boone Gorges almost 3 years ago

  • Related to Bug #6746: bp-multiple-forum-post activity "backfilling" is sometimes causing infinite query loop added

#2 Updated by Boone Gorges almost 3 years ago

  • Status changed from New to Resolved

https://github.com/cuny-academic-commons/bp-multiple-forum-post/commit/74b7c368b682d30733a88eca69fc7b0e4417835a looks like it skirts the issue. I'm not 100% certain that the heartbeat now works as intended, but this is a small problem compared to the database i/o of the original bug.

https://github.com/cuny-academic-commons/bp-multiple-forum-post/commit/51801c3019a3c0a13869b5996b54c0c8b1183db1 is a related change that reduces the database overhead required when querying for duplicate activity items.

Merged to the Commons in https://github.com/cuny-academic-commons/cac/commit/b5e5df274bea469ae01215e6e603ff3dd544a9be and deployed as a hotfix.

Also available in: Atom PDF