Project

General

Profile

Bug #11000

SSL / link redirection issue for DH Week site from NYCDH homepage

Added by Matt Gold over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Start date:
2019-01-23
Due date:
% Done:

0%

Estimated time:

Description

Hi Ray,

On the homepage of the NYCDH site ( http://nycdh.org ), there is a link in the welcome text widget that goes to http://dhweek.nycdh.org ). As you can see in the attached screenshot, it is an http link, but when I mouse over it in Chrome, it shows as an https link. And when I click on it, it goes, strangely, to a ws.gc.cuny.edu login site, which suggests a redirection problem. do you have any sense of what is going on here?

Screen Shot 2019-01-23 at 8.57.21 PM.png (25.5 KB) Screen Shot 2019-01-23 at 8.57.21 PM.png widget text Matt Gold, 2019-01-23 08:59 PM
Screen Shot 2019-01-23 at 9.00.16 PM.png (277 KB) Screen Shot 2019-01-23 at 9.00.16 PM.png ws redirection Matt Gold, 2019-01-23 09:00 PM
Screen_Shot_2019-01-23_at_9_01_23_PM.png (1.12 MB) Screen_Shot_2019-01-23_at_9_01_23_PM.png annotated homepage screenshot Matt Gold, 2019-01-23 09:02 PM
Screen Shot 2019-01-24 at 12.24.49 PM.png (2 MB) Screen Shot 2019-01-24 at 12.24.49 PM.png Jesse Merandy, 2019-01-24 12:25 PM

Related issues

Related to NYCDH Community Site - Bug #11013: Convert subdomain install to subdirectory installResolved2019-01-24

History

#1 Updated by Raymond Hoh over 2 years ago

Hi Matt,

I'm afraid I cannot replicate the problem over here. Does this only occur within the campus network?

#2 Updated by Matt Gold over 2 years ago

This is happening for me at home. I can check from the campus network later today. Jesse and Kimon, are you seeing this?

FYI, I am on a Mac and using Chrome. I just realized that I am using the HTTPS Everywhere extension on Chrome -- https://chrome.google.com/webstore/detail/https-everywhere/gcbommkclmclpchllfjekcdonpmejbdp . Perhaps that is why I am seeing this?

#3 Updated by Jesse Merandy over 2 years ago

I am able to click through to the correct destination from work. My page is showing the non https link on hover over

#4 Updated by Raymond Hoh over 2 years ago

I just realized that I am using the HTTPS Everywhere extension on Chrome

Yes, this is the cause due to our problem with not having a wildcard SSL certificate (what we were talking about on Tuesday).

I'll add a ticket about converting NYCDH's subdomain install to a subdirectory one now so we can track it and do something about it after DH Week.

#5 Updated by Matt Gold over 2 years ago

  • Status changed from Assigned to Rejected

Okay -- great. Thanks to you both!

#6 Updated by Raymond Hoh over 2 years ago

  • Related to Bug #11013: Convert subdomain install to subdirectory install added

Also available in: Atom PDF