Project

General

Profile

Support #11211

user needs to edit the HTML coding

Added by Marilyn Weber over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
WordPress Themes
Target version:
Start date:
2019-03-11
Due date:
% Done:

0%

Estimated time:

Description

User Matthew Conlin writes
"I was wondering if there's a way to edit the HTML coding on my site. There's a glitch that removes the Facebook button from our top menu, and I have the proper code to fix it but I need to know where I can open the HTML editor. I have attached examples. Any advice would be appreciated."

I suggested that he use Edit CSS but he replies "CSS is definitely helpful to stylize it in the top menu to our liking, but the problem is that the glitch has erased the actual HTML code in that spot, so I can’t CSS stylize what isn’t there in the HTML."

MC3.JPG (27.9 KB) MC3.JPG Marilyn Weber, 2019-03-11 03:52 PM
MC1.JPG (20.7 KB) MC1.JPG Marilyn Weber, 2019-03-11 03:52 PM
MC2.JPG (22.8 KB) MC2.JPG Marilyn Weber, 2019-03-11 03:52 PM

Related issues

Is duplicate of CUNY Academic Commons - Bug #10588: Missing social icons in Lucid ThemeResolved2018-10-242018-10-30

History

#1 Updated by Boone Gorges over 2 years ago

  • Status changed from New to Reporter Feedback

It's not possible for users to edit the HTML that's hardcoded into theme templates.

If the user could share a link and details about the specific element that needs fixing (including info about how the Facebook link was originally configured), I can look to see whether there's a way to fix without resorting to a child theme.

#2 Updated by Marilyn Weber over 2 years ago

"Thank you so much for looking into it. Our page is using the Lucid Theme. In it, it gives the option to add a social media button (image below). I think what may have happened is one of the our installed plug-ins overrode it somehow, which has happened once before. However, we need those plug-ins for our site to operate accessibility features so I can’t delete them. Currently the HTML code looks like this:
The thing that went missing is the class inside it, which should look something like:
<div id=“social-icons”>
<a class=”fbook” href=“(our facebook page)” title= Facebook</a>
</div>
Then I could stylize it how I need with CSS because it would have a point of reference. We have time before our publication launch in summer, but the sooner it’s resolved, the better. If I can’t edit HTML, I appreciate any recommendation."

#3 Updated by Boone Gorges over 2 years ago

Thanks for passing this along, Marilyn. Could you please ask for a link, or provide me the link if you've already got it?

#4 Updated by Marilyn Weber over 2 years ago

He hasn't given it yet but I've asked again.

#6 Updated by Boone Gorges over 2 years ago

  • Category name set to WordPress Themes
  • Status changed from Reporter Feedback to Staged for Production Release
  • Target version set to 1.14.8

Thanks very much for the details. This is a recurrence of #10588, which I fixed previously on the Commons. I submitted a report to the theme authors, but apparently they ignored it and shipped a new version anyway. Fix reapplied in https://github.com/cuny-academic-commons/cac/commit/d61c9233ab5051e9a07d193e4485995ba7d42221. This will be part of tomorrow's release.

#7 Updated by Boone Gorges over 2 years ago

  • Is duplicate of Bug #10588: Missing social icons in Lucid Theme added

#8 Updated by Boone Gorges over 2 years ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF