Project

General

Profile

Bug #11501

Error message when editing post

Added by Gina Cherry over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
Start date:
2019-05-29
Due date:
% Done:

0%

Estimated time:

Description

I set up a brand new group and web site. When I went to edit the existing "Hello World" blog post, I saw this error message: https://screencast.com/t/aQY36QTOYm62

The web site is https://bmccopenpedagogy.commons.gc.cuny.edu


Related issues

Related to CUNY Academic Commons - Feature #11504: Deprecate cets_EmbedRSS pluginResolved2019-05-30

History

#1 Updated by Boone Gorges over 2 years ago

It looks like this is coming from a plugin. Can you please share details on how you set up the group+site? Which "layout" did you choose - Default, Teaching, etc? After creation, did you activate any plugins or plugin packages?

#2 Updated by Gina Cherry over 2 years ago

I selected Teaching, but what I got was Default. I changed the theme, but did not activate any plug-ins.

#3 Updated by Boone Gorges over 2 years ago

#4 Updated by Boone Gorges over 2 years ago

  • Target version set to 1.15.3

Thanks for the feedback.

The immediate issue is that there's a bug in the network-activated cets_EmbedRSS plugin that causes its TinyMCE plugin to be requested from a http:// URL rather than https://. This has been fixed in https://github.com/cuny-academic-commons/cac/commit/8a213be24e4d5bc7d760ae121c35644240474293 and deployed immediately to the production site, so that you shouldn't see the notice anymore.

There's a broader question of why the cets_EmbedRSS plugin is network activated. I've opened #11504 to track this.

Regarding site layouts, I can see in the database that your newly created site does not, in fact, have any associated layout - the layout tool appears somehow not to have kicked in. Can you please confirm that your exact steps were as follows: 1. Visit https://commons.gc.cuny.edu/create; 2. Select 'Create Group + Site'; 3. Select the Teaching Layout from the Add Site step. I was NOT able to reproduce the issue when taking these steps. If you created your site in a different way (say, creating a standalone group, then adding a site later via the Manage tab of the group), it would help me to narrow down the potential problem.

#5 Updated by Gina Cherry over 2 years ago

Yes, those are the steps that I took to create the group and site.

#6 Updated by Boone Gorges over 2 years ago

  • Status changed from New to Resolved

Thanks. Looking at the last few hundred sites created on the Commons, it looks like there are only two or three that don't have their cac_site_template_id set. So there's likely a bug here, but it's not widespread, and I'm not sure what steps to take to diagnose. I'll likely wait to hear if I get other reports, to see if a pattern emerges.

In the meantime, we've resolved the primary issue in this ticket.

#7 Updated by Gina Cherry over 2 years ago

FWIW, I just went through the steps again and was also not able to reproduce the issue. In the process, I also noticed that if you create a group from the My Groups page, you don't get the Create Group + Site option that you get when creating a group from the Groups Directory page.

#8 Updated by Gina Cherry over 2 years ago

Would it be possible to apply the Teaching layout to the site that I already created? The url is https://bmccopenpedagogy.commons.gc.cuny.edu

Thanks!

Also available in: Atom PDF