Project

General

Profile

Bug #11508

Bug with "Send to Group"

Added by Gina Cherry over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
Start date:
2019-05-31
Due date:
% Done:

0%

Estimated time:

Description

Unchecking "send to group" does not work on my new site, https://bmccopenpedagogy.commons.gc.cuny.edu/

I unchecked "Send to Group" and immediately clicked the publish button. I tried this 3 times. All 3 posts were sent to the group.

History

#1 Updated by Boone Gorges over 2 years ago

  • Status changed from New to Reporter Feedback

Gina, could you please share details? Please give links to the blog posts in question, and share screenshots or some other information that indicates how they were "sent to group". I ask because I don't see at https://commons.gc.cuny.edu/groups/bmcc-open-pedagogy-seminar/ any indication that there were activity items created for new blog posts, which means that email notifications would not have gone out. It's also possible that what you saw were "edited" notifications rather than "new post" notifications, which could indicate a different sort of interface issue, but it's hard to know without details.

#2 Updated by Gina Cherry over 2 years ago

#3 Updated by Boone Gorges over 2 years ago

  • Target version set to 1.15.3

Thanks for the additional details.

It appears that there was a problem with the way 'Send to group' worked in the context of asynchronous email notification sending; in order for it to be compatible, we need to save the 'Send to group' setting in a persistent way. This change was fairly straightforward in the case of the Classic editor, but was deeply complicated in the case of the Block editor.

https://github.com/cuny-academic-commons/cac/commit/83ef20c34e05c5ee2dcb1666654f5908b034e3e5
https://github.com/cuny-academic-commons/cac/commit/5a8403c08c307a29de8c680db1bac84ffc3499ed

I've deployed this as a hotfix to production and have verified that it appears to be working.

#4 Updated by Boone Gorges over 2 years ago

  • Status changed from Reporter Feedback to Resolved

Also available in: Atom PDF