Project

General

Profile

Bug #117

Links which go nowhere

Added by Manfred Kuechler almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Upgrades
Target version:
-
Start date:
2009-12-05
Due date:
% Done:

0%

Estimated time:

Description

I clicked on a link which seems to point to the text of a posting, but get to a generic site unrelated to this posting. Watch the video: http://screencast.com/t/NTBkZWExYjI

History

#1 Updated by Matt Gold almost 10 years ago

  • Category name set to Upgrades
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

Thanks for reporting this, Manfred. The news feed link you clicked on goes to activity in a private group, so it's understandable why you weren't able to see it. But you're right that instead of redirecting you to the home page, which is confusing, you should be taken instead to the home page of the group (which would show that it is private) and/or to a message that would tell you that you have requested to look at information in a private group to which you don't belong.

We'll also look into addressing the fundamental problem, which is that users shouldn't see news items from private groups to which they do not belong.

#2 Updated by Matt Gold almost 10 years ago

  • Assignee changed from Boone Gorges to Matt Gold

#3 Updated by Matt Gold almost 10 years ago

  • Status changed from Assigned to Resolved

This turned out to be a problem caused by that particular group. A test group we had created during the upgrade process somehow got partially mapped onto the CUNY Technology Group. Activity from private groups <strong>does not</strong> post to the news page, but in this case the public group (CTG) was posting to the news page but getting linked to the private group (test group for boone). We have untangled the problem and corrected the activity items that were confused.

I am closing this ticket because the issues has been fixed. If it arises again, you can continue to update this ticket and we will re-open it.

Also available in: Atom PDF