Project

General

Profile

Bug #12036

Blog post notification not sent to group

Added by Gina Cherry almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
Email Notifications
Target version:
-
Start date:
2019-10-31
Due date:
% Done:

0%

Estimated time:

Description

I published a blog post today and no email notification was sent to members of the group to which the blog is connected. I even tried reverting to draft and re-publishing - no email notification. "Send to group" was definitely checked and the notification did not go to spam. The post appears in recent group activity. My subscription options are set to All Email. Any ideas?

https://cetls.bmcc.cuny.edu/blog/2019/10/31/online-discussion/


Related issues

Related to CUNY Academic Commons - Feature #12042: Improved error logging for BPGES send queueNew2019-11-04

History

#1 Updated by Boone Gorges almost 2 years ago

  • Category name set to Email Notifications
  • Status changed from New to Reporter Feedback

Here's what I see:

- The blog post was published at Oct 31, 2019 @ 10:32
- An activity stream item was generated by the blog post with ID 600491 at 2019-10-31 15:32:13
- At 2019-10-31 15:32:13 (immediately after the activity item was created), the group email subscription log shows the entry "Beginning batch of immediate notifications for 600491." This confirms that 'Send to group' was indeed checked.
- At 2019-10-31 15:32:19 (six seconds later), the log reads "Finished sending immediate notifications for 600491. A total of 73 notifications were sent over all batches." The CETLS group https://commons.gc.cuny.edu/groups/bmcc-cetls/ has 91 members, but this suggests that 73 have the 'All Mail' setting.

All of the above looks like correct, expected behavior. This leaves open a couple possibilities:
a) The log is incorrect, particularly at the end - it says it actually sent the notifications, but it didn't do so. Given that other notices are being sent by the site (I just got one for a different group), I'd be surprised to hear that this is the case, but it could be a fluke
b) There was a problem between the time when PHP triggered the sending of the emails and the time it reached the inbox. Much of this sending is a black box, unfortunately. I can follow up with GC IT to get access to the proper mail logs to ensure that the emails actually left the server, but beyond that, there's a hundred places where it might have been caught in a spam filter or otherwise lost in the ether.

There's also a chance that the emails were actually sent, but that there was a problem for your email account. Have you checked with other group members to confirm that they too did not receive the notification?

As a side note, unpublishing and republishing alone would not generally be an effective way to trigger a resend. Email notifications are triggered by the creation of an activity item, so you'd need to delete that activity item and then regenerate it by republishing the post.

#2 Updated by Gina Cherry almost 2 years ago

Two other group members (Jim Berg and John Beaumont) report that they did not receive the notification. I have been receiving other notifications from the Commons, including for a comment on the blog post in question (a comment that was held for moderation, but nevertheless triggered a notification by the Commons, as described here: https://redmine.gc.cuny.edu/issues/12004#change-46282

#3 Updated by Boone Gorges almost 2 years ago

Thanks, Gina. Can you confirm that you've received other email notifications for posts in that very group? Looks like there were a few last week, on the 25th.

#4 Updated by Gina Cherry almost 2 years ago

Yes. As I mentioned, I received a notification for a comment on that very post. And for every other blog post (posts are published approximately once a week) and comment on a blog post.

#5 Updated by Boone Gorges almost 2 years ago

Thanks. I ask specifically about the blog post, because blog comment notifications are sent by a different mechanism.

I'll reach out to IT to get access to the mail logs so that I can confirm that nothing went wrong on the Commons end.

If you'd like, you can also try deleting the activity item in the CETLS group, unpublishing the post, and republishing it, to see whether the notifications are received. If so, then I guess the best we can do is to chalk it up to a momentary lapse in the system. Alternatively, we can wait until the next CETLS post is ready to be published, and monitor to see whether those notifications are received.

#6 Updated by Gina Cherry almost 2 years ago

I deleted the activity in the CETLS group, unpublished and republished. This time I received a notification.

#7 Updated by Boone Gorges almost 2 years ago

Thanks for confirming. I'll let you know when I've got info from the mail logs.

#8 Updated by Boone Gorges almost 2 years ago

  • Related to Feature #12042: Improved error logging for BPGES send queue added

#9 Updated by Boone Gorges almost 2 years ago

  • Status changed from Reporter Feedback to Resolved

I've got access to the mail logs and have been looking through them. I can't seem to find a set of emails corresponding to the 2019-10-31 send. This means that there was a disconnect between the BPGES system - which says that emails were sent - and the outgoing email system on the server.

The code in the BPGES system doesn't have fine-grained logging tools for this purpose. In particular, it can't distinguish between different types of failures: absent or broken email addresses; postman/mailer errors; etc. This means that there's no way at the moment to diagnose the exact nature of the issue in this case. I'll work on improved logging for BPGES so that we can troubleshoot better in the future.

In the meantime, I think we can conclude the following:
a. This was an isolated incident that doesn't appear to be fully general, since other blog posts are sending notifications as expected
b. You've now got a mechanism for retriggering the send process (deleting the activity item and republishing)

As such, I'm going to close this ticket and track future improvements in logging as part of #12042. Please do let us know - here or in a new ticket - if you experience this issue again. Thanks for your patience.

Also available in: Atom PDF