Project

General

Profile

Bug #12250

Featured course slider nav elements are sometimes hidden

Added by Boone Gorges over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Courses
Target version:
Start date:
2020-01-03
Due date:
% Done:

0%

Estimated time:

Description

I don't see a pattern at a glance, but on the current set of featured courses, the nav only appears for about 2 out of 5 courses. https://commons.gc.cuny.edu/courses/# It probably has something to do with z-index?

History

#1 Updated by Boone Gorges over 1 year ago

  • Target version changed from 1.16.3 to 1.16.4

#2 Updated by Boone Gorges over 1 year ago

  • Target version changed from 1.16.4 to 1.16.5

#3 Updated by Boone Gorges over 1 year ago

  • Target version changed from 1.16.5 to 1.16.6

#4 Updated by Boone Gorges over 1 year ago

  • Target version changed from 1.16.6 to 1.16.7

#5 Updated by Boone Gorges over 1 year ago

  • Target version changed from 1.16.7 to 1.16.8

#6 Updated by Boone Gorges over 1 year ago

  • Status changed from New to Resolved

Finally managed to reproduce this on the production site. Looks like the problem is that the slider library uses z-index:2 for the active element, which was causing a race condition of sorts with the nav elements. Fixed in https://github.com/cuny-academic-commons/cac/commit/8c762758d01f76b3087688585700188e96f3e936

Also available in: Atom PDF