Project

General

Profile

Support #13716

Events sidebar issue with segalcenter.org

Added by scott voth 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
WordPress Plugins
Target version:
-
Start date:
2020-12-17
Due date:
% Done:

0%

Estimated time:

Description

Page where the problem exists: https://thesegalcenter.commons.gc.cuny.edu/events/

Basic issue: Events sidebar shows extraneous content before the content is should show.

Andie Lerner writes:

"The issue began last Friday.

However, what happened is that the public view (segalcenter.org) was unreachable with an error message reading "The CUNY Academic Commons is experiencing issues" and "Under Maintenance" listed on the tab. I contacted Marilyn initially confirming whether or not this was only with my Commons site or if it was happening widespread? It was at this point that she contacted dev and gave me access, and the site began working again. From her point of view nobody had used the site since 2018, however I have been logging in to the commons through our admin account and adding events since spring. After this step, I logged in and readied the MESTC theme, since it was no longer applied to the site, and the sidebar became what it is now. ​I know that was long winded, but I wanted to give you a complete view of what happened to explain the more minute issue."

I tried a long time to fix the sidebar issue on the events page, but no luck. Attached please see current display. The content highlighted in red should not appear. The plugin "Custom Sidebars" is being used, but I can't figure out how the desired content is getting into the sidebar. I think the undesired content comes from the "Primary aside."

I went to the internet archive to see what the Events page should look like. See Attached.

I do see this notice: "Custom Sidebars Notice
Starting from version 5.7, WordPress will be using Gutenberg's block-based Widget Screen. Custom Sidebars is not compatible due to the fact that once Full Site Editing is in place, such plugins will not be required anymore. Therefore Custom Sidebars has been discontinued. If you have existing sidebars that you need to modify, you can switch back to a legacy Widgets screen by adding remove_theme_support( 'widgets-block-editor' ); in your theme's functions.php file. You can read more about this here. "

But it seems it should still work with the theme.

way back events page.png (860 KB) way back events page.png scott voth, 2020-12-17 01:51 PM
current events screen.png (1.26 MB) current events screen.png scott voth, 2020-12-17 02:03 PM

History

#1 Updated by Boone Gorges 10 months ago

When I visit https://www.thesegalcenter.org/events/, if I scroll down the page, I see headers 'Spring 2019 Season' and 'Past Events' that match the Wayback Machine screenshot. Do others see that as well? Am I therefore correct that the problem is just that the section with 'Join Mailing List' and 'Support MESTC' is instead replaced with the large list of page links?

#2 Updated by scott voth 10 months ago

Yes, I believe that is correct. The events page needs to add 'Join Mailing List' and 'Support MESTC' and it needs to get rid of all the page links, but keep the event links.

#3 Updated by Boone Gorges 10 months ago

  • Status changed from New to Reporter Feedback

Thanks for the clarification. I see at https://www.thesegalcenter.org/wp-admin/customize.php?return=%2Fwp-admin%2F (navigate to Widgets) that the unwanted widgets appear in the 'Primary Aside' and 'Secondary Aside' sidebars. If they're removed from those sidebars, they also disappear from the /events/ page. I didn't save these changes, as I wasn't sure whether it would affect other parts of the site.

As for why this changed, it's possible that a plugin was being used to customize the way that widgets appear on different pages of the site, and that the plugin broke with a recent update. Perhaps the 'Custom Sidebars' plugin has something to do with this, but I'm not familiar with the way the plugin is designed to work, so I can't see at a glance what might be going wrong.

#4 Updated by scott voth 10 months ago

  • Status changed from Reporter Feedback to Resolved

Thanks for your insights! I created a blank sidebar, and on the events page replaced both the primary and secondary asides to it. That seems to work and does not affect other pages (especially the publications page). Haven't heard back, but am closing this for now. I think we can handle this going forward.

#5 Updated by Boone Gorges 10 months ago

Great, thanks!

Also available in: Atom PDF