Project

General

Profile

Bug #14483

Wordpress PDF Embed Stopped Working after JITP Media Clone

Added by Patrick DeDauw 5 months ago. Updated 5 months ago.

Status:
Reporter Feedback
Priority name:
Normal
Assignee:
Category name:
WordPress - Media
Target version:
Start date:
2021-05-20
Due date:
% Done:

0%

Estimated time:

Description

Hi Boone,

Thanks so much for your help on the JITP library transfer—everything went great with the issue launch, and I really appreciate how quickly you fixed the redirect hiccup.

We have noticed that our pdf embedder on the page below has started turning up "Failed to Fetch" errors when viewed in Chrome, though not in Safari. I tried re-uploading the pdfs and changing the links, in case it was an issue of the Media Library clone, but found it still not working. I've since tried a few variations (adding www. to the pdf url, trying http://) to no avail.

https://jitp.commons.gc.cuny.edu/developing-a-coronavirus-covid-19-case-study-using-google-docs-in-a-master-of-public-health-student-cohort/

For your reference, the urls in question are

https://jitp.commons.gc.cuny.edu/wp-content/blogs.dir/614/files/2021/03/Appendix-A-Gonzalez-COVID19-Case-Study-Final-1.pdf
and
https://jitp.commons.gc.cuny.edu/wp-content/blogs.dir/614/files/2021/03/Appendix-B-Gonzalez-Student-Reflection-Quotes-1.pdf

and they are set to display toward the bottom of the post (under "Appendix A" and "Appendix B").

All my best,

Patrick

History

#1 Updated by Boone Gorges 5 months ago

  • Status changed from New to Reporter Feedback

Thanks for the detailed report, Patrick.

The problem here is that the PDF embedding plugin is attempting to load the file from an insecure URL (http vs https). I'm unsure what the root cause for this is, but I was able to skirt the problem by changing the URLs in the post content from this format:

https://jitp.commons.gc.cuny.edu/wp-content/blogs.dir/614/files/2021/03/Appendix-A-Gonzalez-COVID19-Case-Study-Final-1.pdf

to this format:

https://jitp.commons.gc.cuny.edu/wp-content/files/2021/03/Appendix-A-Gonzalez-COVID19-Case-Study-Final-1.pdf

Note that I removed the section of the URL that says 'blogs.dir/614/'.

Since this is likely a one-off problem that occurred due to the way the media library was cloned, I think this is a sufficient fix for the time being. Can you review and see if it's working as expected?

#2 Updated by Patrick DeDauw 5 months ago

Hi Boone,

Looks great! I'll keep this in the mind and check it first in case of trouble in the future. Thanks so much for fixing this so quickly!

All my best,

Patrick

Also available in: Atom PDF