Project

General

Profile

Bug #14509

Elementor Editor problem

Added by Marilyn Weber 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
WordPress Plugins
Target version:
Start date:
2021-05-28
Due date:
% Done:

0%

Estimated time:

Description

Juwon Jun reports:
"I'm attempting to edit pages that use the Elementor Editor plugin on our symposium website (https://8nsshl2021.commons.gc.cuny.edu?) but for an unknown reason, the update/publish button seems to have vanished from the editor. I have tried searching for help on Elementor's website and used different browsers (disabled extensions) with no luck."

Screenshot attached. They have been using Elementor for a while now, and I'm convinced this isn't user error

Screen Shot 2021-05-28 at 11.11.08 AM.png (1.71 MB) Screen Shot 2021-05-28 at 11.11.08 AM.png Marilyn Weber, 2021-05-28 11:20 AM
elementor footer.jpg (315 KB) elementor footer.jpg scott voth, 2021-06-01 02:07 PM

History

#1 Updated by Boone Gorges 4 months ago

I've never used Elementor, so I'm unsure of the intended behavior. Where does the update/publish button usually appear? Is it an option in the left-hand sidebar?

#2 Updated by Marilyn Weber 4 months ago

"I recall it as a green, rectangular button in the lower-left hand corner of that sidebar."

#3 Updated by Boone Gorges 4 months ago

  • Status changed from New to Reporter Feedback
  • Target version set to 1.18.12

Another user reported the same issue via ZenDesk and email, and she was able to determine that the button was being rendered just off the bottom of the screen. This allowed me to determine that a recent change in Elementor (apparently connected to hiding the WP admin bar) caused a conflict with some of our custom styling related to the admin bar. I've just put a hotfix in place that appears to solve the problem: https://github.com/cuny-academic-commons/cac/commit/0850c628dcd9f5528156eedfb8e42277329161bc

#4 Updated by Marilyn Weber 4 months ago

Thanks. Who was the other user? I'm not seeing it on ZD

#5 Updated by Boone Gorges 4 months ago

It was Pamela Stemberg - we started emailing directly after another recent ticket.

#6 Updated by scott voth 4 months ago

If it helps any, here is what the Publish/Save button looks like and its markup.

#7 Updated by Boone Gorges 3 months ago

  • Category name set to WordPress Plugins
  • Status changed from Reporter Feedback to Resolved

Thanks, Scott. I believe that my fixes resolved this problem.

Also available in: Atom PDF