Project

General

Profile

Bug #14841

Issue with Co-Authors Plus in the Customizr theme

Added by Gina Cherry 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2021-10-05
Due date:
% Done:

0%

Estimated time:

Description

Guest authors created with the Co-Authors Plus plug-in are not displayed at the end of blog posts in Customizr. Here is the site in question: https://abiseminaralums.commons.gc.cuny.edu/.

The Enable Co-Authors Filters plug-in is active.

Authors display correctly when set to Commons users, but not when set to guest authors created in the plug-in. See the published posts here for examples of authors not displaying: https://abiseminaralums.commons.gc.cuny.edu/faculty-projects/

See this unpublished test post for an example of a Commons author displaying correctly: https://abiseminaralums.commons.gc.cuny.edu/wp-admin/post.php?post=134&action=edit

History

#1 Updated by Raymond Hoh 4 months ago

Hi Gina,

It looks like guest authors are working correctly. For your linked page: https://abiseminaralums.commons.gc.cuny.edu/faculty-projects/. The second post, "Reflection Paper on Intersectional Identities", is by a guest author: https://abiseminaralums.commons.gc.cuny.edu/author/michael-mcgee/.

It looks like your site has a mixture of both real users and guest authors. Perhaps you are assigning the wrong author to some of the posts? You might want to audit your list of guest authors to ensure you have the proper ones assigned: https://abiseminaralums.commons.gc.cuny.edu/wp-admin/users.php?page=view-guest-authors

If there is still an issue, can you clarify what the problem is for specific pages or guest authors?

#2 Updated by Gina Cherry 4 months ago

Hi Raymond,

Guest authors are not working correctly. I have done extensive testing with switching between Commons authors and guest authors. The correct author is assigned to a post regardless of whether the author is a guest or a Commons author; however, the author bio is only displayed at the bottom of the post for Commons authors, not for guest authors. See my links to examples above.

#3 Updated by Raymond Hoh 4 months ago

Oh, I see what you mean now.

Guest authors are working correctly. It's just that the guest author's bio is not displayed at the end of the post. I'll take a look to see what is possible.

#4 Updated by Raymond Hoh 4 months ago

  • Category name set to WordPress Plugins
  • Assignee set to Raymond Hoh
  • Target version set to 1.18.20

Hi Gina,

I've put up some preliminary code on production to address the guest author bio issue at the end of a post page. Let me know if you spot any issues.

#5 Updated by Gina Cherry 4 months ago

Thanks so much for the quick turnaround! So far, it looks great.

#6 Updated by Raymond Hoh 4 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF