Project

General

Profile

Actions

Support #16531

closed

Display Eventbrite Event

Added by Marilyn Weber 2 months ago. Updated 15 days ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
WordPress Themes
Target version:
Start date:
2022-07-26
Due date:
% Done:

0%

Estimated time:

Description

via zd:

"Firstly, I would like to thank everyone on the CUNY Academic Commons team. I have utilized this resource numerous times with very good results. The only thing I am curious about is a plugin that is approved for use on CAC. The plugin is called, “Display Eventbrite Events (https://fullworksplugins.com/products/widget-for-eventbrite/) .” I built a website for a program within our school and the program would like to display Eventbrite events on a webpage, but the catch is the events are private and only the paid version of this plugin with display private events from Eventbrite API on a webpage. So, my question is could we purchase and implement the paid version of this plugin on CAC?

The website that I am looking to expand and implement this functionality on is below. Also, side note I am a WordPress-er and have been working with coding and developing on the CMS for some years now and I understand why you lock down certain functionality for CAC, but I am hoping we can possibly implement this.

https://hstrs.commons.gc.cuny.edu/

If you have any questions, please do not hesitate to email or call me.

Jake


Jacob Gutte

Actions #1

Updated by Boone Gorges 2 months ago

  • Status changed from New to Reporter Feedback

Here's more information on our policies surrounding proprietary/paid plugins: https://dev.commons.gc.cuny.edu/hosting-partner-handbook/ (see section 2.2)

In this case, if Jake is able to purchase and maintain a license for the paid version, we can likely accommodate it. I've got some technical questions about how the Pro version works, which can only be answered after seeing the Pro plugin files. So I'd recommend that Jake start the free trial described at the website, download the plugin zip, and send along to me. Then, I can assess exactly how it will work alongside the free option (which we must continue to provide to our existing users).

Actions #2

Updated by Marilyn Weber about 1 month ago

He replies

I reached out to Fullworks Digital Ltd. and they confirmed that the paid version of their plugin is a sperate plugin from their free version they offer. Below is the email response I received from the company. We will maintain the license for the paid plugin, but maybe we can setup a quick phone call so we can iron out and clarify any of the details so we can implement this paid plugin. I am available anytime to chat (845.527.1494).


We deliver a new premium plugin and a licence code. You deactivate the free plugin, activate the premium and apply the licence code when prompted. You get an email with these details on purchase.

Just for your reference, no free plugin on Wordpress.org is allowed to simply have an activation code that enables hidden code, all premium code must be in a separate replacement plugin or separate add-on plugin, that iswordpress.org rules.

Hope that answers your question

Best regards,

Alan


Thanks,

Jake


Jacob Gutter

Publications Design / Production Coordinator

Silberman School of Social Work at Hunter College

Actions #3

Updated by Boone Gorges about 1 month ago

Thanks, Marilyn. Based on this, it seems like it should be OK to run on the Commons. Let Jake know that he can make the purchase and send us the zip file. From there, I'll include the plugin in an upcoming release, making it visible only on hstrs.commons.gc.cuny.edu. Once deployed to production, Jake will be able to activate and enter the license key.

Actions #4

Updated by Marilyn Weber 30 days ago

Should he email it to ?

Actions #5

Updated by Boone Gorges 30 days ago

Yes, that should be fine.

Actions #6

Updated by Marilyn Weber 20 days ago

He just got in touch, should be emailing you soon.

Actions #7

Updated by Boone Gorges 16 days ago

  • Category name set to WordPress Themes
  • Status changed from Reporter Feedback to Staged for Production Release
  • Target version set to 2.0.7

Jacob has sent the plugin and I've added it in https://github.com/cuny-academic-commons/cac/commit/93116314c124874d698a2540106f70e74fd6d947

A few notes on implementation. The plugin came in a zipped directory called 'freemius-premium'. This does not accurately describe what the plugin does, and I'm guessing it's a remnant of the way that the developer has the local environment configured. Moreover, the plugin appeared to be zipped in such a way that it included both the free and non-free version of the plugin; the freemius-premium top-level directory contained the free plugin, while a subfolder freemius-premium/freemius-premium contained the non-free plugin.

As such, I've taken that subfolder freemius-premium/freemius-premium, renamed it widget-for-eventbrite-api (matching the textdomain), and added it to the repo in https://github.com/cuny-academic-commons/cac/commit/93116314c124874d698a2540106f70e74fd6d947. I've looked over the codebase and I'm pretty sure this will work - there are no references to freemius-premium, and all paths are relative.

As I'm not really sure how the plugin is intended to work, we'll have to wait until after tomorrow's release for the user to verify that it's functioning properly.

Actions #8

Updated by Boone Gorges 15 days ago

  • Status changed from Staged for Production Release to Resolved
Actions

Also available in: Atom PDF