Project

General

Profile

Actions

Feature #2521

closed

Import Blogroll With Categories Issue

Added by Gregory Donovan about 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2013-03-21
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

Hi Boone - Thanks again for installing the Import Blogroll With Categories plugin. However, when I go to import links I receive the following message instead of the normal import options "Cheatin’ uh?"

I'm guessing this is permissions issue?

Actions #1

Updated by Boone Gorges about 11 years ago

when I go to import links

Can you please be more specific about this? The exact links you're clicking, and/or URLs.

Actions #2

Updated by Gregory Donovan about 11 years ago

Sure - In the dashboard, under Tools > Import > Blogroll With Categories

This page ( http://careerplan.commons.gc.cuny.edu/wp-admin/admin.php?import=bwc_opml ) should provide me with a form that allows me to import an OPML file via URL or by uploading it. Instead, I just get a "Cheatin’ uh?" message.

Actions #3

Updated by Boone Gorges about 11 years ago

Could you please verify the username that you use to access the Commons?

Actions #4

Updated by Gregory Donovan about 11 years ago

Sure - gdonovan

Actions #5

Updated by Boone Gorges about 11 years ago

  • Status changed from New to Reporter Feedback
  • Assignee set to Boone Gorges
  • Target version set to Not tracked

Thanks Greg. Looks like I'd missed one of the checks. Please try again.

Actions #6

Updated by Gregory Donovan about 11 years ago

Thanks, Boone - I can now see the import options when I go to Tools > Import > Blogroll With Categories. But when I try to import the OPML file either by uploading it or via URL, I then get the "Cheatin’ uh?" message and no links are imported.

The "Links" section of the dashboard is also now unavailable and instead delivers the
"Cheatin’ uh?" message as well. If I try to click on one of the Links sub menus in dashboard (i.e. Links > Import) I get a "You do not have sufficient permissions to access this page" message.

Actions #7

Updated by Boone Gorges about 11 years ago

Ugh, there was another check I missed. Can you try again please?

Actions #8

Updated by Gregory Donovan about 11 years ago

No worries - Almost there! The links (and their categories) all appeared to import properly but I still get the "Cheatin’ uh?" message when I go to Dashboard > Links.

Actions #9

Updated by Boone Gorges about 11 years ago

I still get the "Cheatin’ uh?" message when I go to Dashboard > Links.

This one is a bit baffling. There might be a WP bug at play here. In https://github.com/castiron/cac/commit/3f7af981e6e624435346c9aa0062d1386c9ee2ae, I put into place a large hack to make the page accessible. Please let me know if it works for you.

Actions #10

Updated by Boone Gorges about 11 years ago

  • Target version changed from Not tracked to 1.4.24
Actions #11

Updated by Gregory Donovan about 11 years ago

Hey Boone - Now the "All Links" and "Add New Links" options don't even show up under Dashboard > Links. And, if I try to go directly to http://careerplan.commons.gc.cuny.edu/wp-admin/link-manager.php I just get the same permissions error.

It appears the links have successfully imported - so the "Import Blogroll With Categories" plugin can now be uninstalled and junked. All we need at this point is the ability to do the standard adding and editing of links though the dashboard.

Actions #12

Updated by Boone Gorges about 11 years ago

  • Status changed from Reporter Feedback to Assigned

OK. I will remove the plugin altogether for the 1.4.24 release.

Actions #13

Updated by Gregory Donovan about 11 years ago

OK - Thanks. What would the estimated time frame be for when we'll have access to the Links section of our dashboard? The office is understandably eager to get started adding/editing links and currently we're unable to do anything along these lines.

Actions #14

Updated by Boone Gorges about 11 years ago

Hi Greg. The plugin will be removed for the 1.4.24 release, which will go live on April 11. (We release on the 1st, 11th, and 21st of every month.) After that release, I will do my best to make sure that removing the plugin was enough to bring back all of the functionality that you're missing.

Actions #15

Updated by Boone Gorges about 11 years ago

  • Status changed from Assigned to Hold

The plugin is removed in https://github.com/castiron/cac/commit/535c6ecac07737597b9436c7f4bbfd76dccc44ec. Gregory, I'll ping you when the release is live in a few hours, and ask you to check that all the functionality is back as expected. Thanks for your patience.

Actions #16

Updated by Boone Gorges about 11 years ago

OK, the release is live. Gregory, would you mind having a look to see if the issues are resolved?

Actions #17

Updated by Gregory Donovan almost 11 years ago

Hey Boone - Still the same problem. There is currently no "Links" section in the dashboard and if I try to go to the Links area via direct URL ( http://careerplan.commons.gc.cuny.edu/wp-admin/link-manager.php ) I get a permissions error.

So, the plugin has been removed and the links have been successfully imported, but we still can't access or even see the Links section.

Actions #18

Updated by Boone Gorges almost 11 years ago

I'm still unable to reproduce a "permissions" problem, though I do see that the Link Manager plugin was not activated on the careerplan. I've activated it, and am now able to access the Links page at http://careerplan.commons.gc.cuny.edu/wp-admin/link-manager.php. Could you verify?

Actions #19

Updated by Gregory Donovan almost 11 years ago

Got it - I had no idea WP removed the links function with their 3.5 update! We're all set now. Many thanks, Boone!

Actions #20

Updated by Boone Gorges almost 11 years ago

  • Status changed from Hold to Resolved

Whoop! Thanks for your patience as this got sorted out.

Actions

Also available in: Atom PDF