Project

General

Profile

Actions

Bug #2762

closed

Unable to Delete Spam Groups

Added by Matt Gold about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority name:
Urgent
Assignee:
Start date:
2013-08-28
Due date:
% Done:

0%

Estimated time:

Description

Hi Ray -

A rash of spam groups have appeared on NYCDH. I thought that marking users as spam and then deleting accounts would delete everything they had done, but it looks like the spam groups stayed.

The problem is that when I try to delete the groups manually in the dashboard - http://nycdh.org/wp-admin/network/admin.php?page=bp-groups - the delete doesn't work. I mark a bunch with checkmarks and then click "delete," but the groups stay.

Can you please make this a high priority and look into this as soon as you can? Many thanks.

Actions #1

Updated by Raymond Hoh about 9 years ago

  • Status changed from Assigned to Resolved

Hi Matt,

Looks like you uncovered a bug. Mass group deletion in the dashboard doesn't appear to work, but single group deletion does.

I just manually deleted the spammed groups.

Will look into patching the groups dashboard bug for BuddyPress.

About a spammer's groups not being deleted, what happens when you delete the user instead?

Actions #2

Updated by Matt Gold about 9 years ago

Cool - thanks so much, Ray, and sorry for not trying that!

Regarding groups, I always do both -- first mark the user as spam, then delete the user.

Actions #3

Updated by Raymond Hoh about 9 years ago

Just to update this ticket, I committed a fix for mass-group deletion a few days ago.

It should make its way into BP 1.9.

Actions #4

Updated by Matt Gold about 9 years ago

Great - thanks, Ray.

Actions

Also available in: Atom PDF