Project

General

Profile

Feature #3088

Child theme for Room4108 Site shows up as blank

Added by Harlan Kellaway almost 8 years ago. Updated almost 8 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
WordPress Themes
Target version:
-
Start date:
2014-03-01
Due date:
% Done:

0%

Estimated time:

Description

Hello --

I entered a request to include a child theme for the Room4108 Site (http://room4108.org) in the update for March 1st (Feature #3074). I see the theme is now available (thank you!) but when I activate it, the home page is just blank. I got it working on a test subsite of my own domani (http://room4108.transfrwith.us/), which is how I developed the child files. Given that works, its hard for me to troubleshoot what's going wrong with this install. SOS!

imbalance2-commons.zip (494 KB) imbalance2-commons.zip Boone Gorges, 2014-03-01 02:47 PM

History

#1 Updated by Boone Gorges almost 8 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

OK. Hands off for a few minutes while I take a look.

#2 Updated by Boone Gorges almost 8 years ago

  • Status changed from Assigned to Reporter Feedback

In your header.php file, you're making reference to a number of nonexistent functions: getColor(), getFonts(), getFavicon(). They're causing fatal errors. Can you give more background on these functions? Did you write them yourself? If so, you forgot to include them in your theme files. Or do they come from a required plugin?

#3 Updated by Harlan Kellaway almost 8 years ago

I did not add those myself. I developed my test child theme with the latest version of Imbalance 2 though, which I think may be different than the one available on the Commons.

#4 Updated by Boone Gorges almost 8 years ago

Can you please give additional details that will help me to debug this? What version of Imbalance 2 did you develop against? Do you have a link to download it? I'm flying a little blind. Thanks.

#5 Updated by Harlan Kellaway almost 8 years ago

I downloaded the latest Imbalance 2 - http://wpshower.com/themes/imbalance-2/

I installed a fresh WordPress instance for my subdomain, uploaded the latest Imabalance 2, and developed my theme off of that.

If it's possible to get a copy of the theme files the Commons uses for Imbalance 2, I could try re-developing with that?

#6 Updated by Boone Gorges almost 8 years ago

  • Status changed from Reporter Feedback to Assigned
  • Target version set to 1.5.20

Thanks for the additional info. I see what's happened.

On the Commons, we're running the version of Imbalance2 that has been forked by Automattic for wordpress.com. They made a number of performance and security fixes to the freely available version of the theme. In addition, it looks like the way the theme options are handled has been modified in the wordpress.com version. So I'm afraid that some additional development will be required to make it work.

I'm attaching a copy of the version of the theme running on the Commons to this ticket. You can also get it via Subversion at https://wpcom-themes.svn.automattic.com/imbalance2/ (if you don't know what that is, don't worry about it).

Sorry for this misunderstanding, and please let me know if you have more questions.

#8 Updated by Harlan Kellaway almost 8 years ago

Okay -- I will use that for further development and submit another ticket when ready to have it included a child theme.

Thanks!

#9 Updated by Boone Gorges almost 8 years ago

  • Status changed from Assigned to Rejected
  • Target version deleted (1.5.20)

Closing this ticket as Rejected. I'll wait for a new ticket with the updated theme. Thanks, Harlan.

Also available in: Atom PDF