Project

General

Profile

Bug #3360

Blog post activity feed link error

Added by Sarah Morgano almost 7 years ago. Updated over 5 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2014-08-04
Due date:
% Done:

0%

Estimated time:

Description

Anne Chamberlain recently posted to her group blog Recruiting Tools. I've attached how it shows up on the page for the group. She wrote:

When you click on the post title “Recruiting and Hiring…” at the top, the link takes you to the post (correctly).

However, clicking on the text below, starting with “Earlier this year” takes you to the photograph at the top of the post, as a jpg file, not to the blog entry.

I don't have access to this group blog so I was not able to further investigate.

blog post activity feed.png (63.4 KB) blog post activity feed.png Sarah Morgano, 2014-08-04 01:01 PM

History

#1 Updated by Boone Gorges almost 7 years ago

  • Category name set to BuddyPress (misc)
  • Status changed from New to Reporter Feedback
  • Assignee set to Boone Gorges
  • Target version set to Not tracked

Sorry for the delay in responding - I appear not to have gotten this email notification.

I've spent a bit of time trying to debug and reproduce, but I've had limited success. What I can see is that:

- the link is being caused by an open anchor tag in the activity stream. This tag is orphaned
- the orphan tag is saved in the database, which is to say that whatever is happening is happening at the time of save

I've tried to trace the problem in a number of ways, even attempting to post another blog post with exactly the same content, but I couldn't reproduce the original issue: the link is not showing up for me.

One possibility that I couldn't verify one way or another is that Anne originally saved the post with an incorrectly formatted link, and then later edited the post to remove the incorrect formatting. Maybe it's worth following up with her about this?

#2 Updated by Boone Gorges over 5 years ago

  • Status changed from Reporter Feedback to Rejected

I haven't seen this issue pop up again. And in the interim, the way that BuddyPress creates excerpts for the activity stream has been revamped. So it's quite possible that whatever corner-case bug was causing the problem in this ticket has magically been resolved :) Please reopen if more details are unearthed.

Also available in: Atom PDF