Project

General

Profile

Bug #4033

ESA site new post-type not viewable

Added by Paul Hebert over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority name:
High
Assignee:
-
Category name:
-
Target version:
Start date:
2015-05-03
Due date:
% Done:

0%

Estimated time:

Description

The ESA commons site added a custom post type to its ArrasESA child theme in the most recent update, 5/1/2015 -- http://gcenglish.commons.gc.cuny.edu

The custom post type ("evaluations") shows up just fine on the dashboard and the editing screen. However, once you've published an evaluation, clicking on the "view evaluation" button does not work. You're brought to a "page not found" error (see screenshots).

On local-server tests, everything worked fine.

Maybe it's an issue with the slug? I edited the slug in the Functions file to create the post. Maybe it's having a problem with my current settings?

Any ideas?

The original ticket to amend the child theme is Support #4026: http://redmine.gc.cuny.edu/issues/4026

001.jpg (182 KB) 001.jpg Custom post dashboard/editing screen Paul Hebert, 2015-05-03 04:07 PM
002.jpg (156 KB) 002.jpg landing page after following "view post" link Paul Hebert, 2015-05-03 04:07 PM
Terms01.jpg (155 KB) Terms01.jpg Paul Hebert, 2015-05-05 01:15 PM
Terms02.jpg (195 KB) Terms02.jpg Paul Hebert, 2015-05-05 01:15 PM

History

#1 Updated by Boone Gorges over 4 years ago

Try refreshing your permalinks. Dashboard > Settings > Permalinks, and resave your existing settings.

#2 Updated by Paul Hebert over 4 years ago

  • Status changed from New to Resolved

Ha ha! It worked. Thanks!

#3 Updated by Boone Gorges over 4 years ago

  • Target version set to Not tracked

Excellent! Pro tip: when plugin authors register post types, they either use `register_activation_hook()` to do a rewrite flush (it's fired on plugin update), or use an 'admin_init' callback to examine rewrite rules and flush if necessary. Not something you have to worry about for a single-use theme, where it's just as easy to do the flush manually, but definitely something to think about if you write anything for public distribution.

#4 Updated by Paul Hebert over 4 years ago

Makes sense. Thanks.

#5 Updated by Paul Hebert over 4 years ago

I don't know if this is related -- but I've noticed that while the custom taxonomies (Professor and Semester) seem to work (they display on the page, exist in the dashboard nav), when you input a term in one of the boxes on the editor screen, it returns no other matching terms.

For example, I know I've entered an evaluation for, say Kandice. When I start typing "Kandice" it displays a 0. Yet, Kandice is registered in the taxonomy for Professor, so the first time I added it, it worked fine. (see screen shots).

Terms01.jpg shows that the taxonomy is working (taxonomy is "professor) and that there are 2 custom posts (evaluations) tagged with Kandice as the Professor.

Terms02.jpg shows me attempting to add Kandice as a professor to another page and the search box pulls up nothing.

#6 Updated by Boone Gorges over 4 years ago

Just did a bit of debugging, and it's not directly related. The problem appears to be that you're using a capital letter in the taxonomy name ('Professor' instead of 'professor'). This causes problems when the 'Professor' string is sent in the AJAX request; it is sanitized to lowercase at https://core.trac.wordpress.org/browser/tags/4.1.4/src/wp-admin/includes/ajax-actions.php?marks=110-111#L100, which causes the taxonomy not to be found. (Similar problems might happen in the case of post type names.)

Can you please verify that changing the taxonomy/post type names to all lowercase fixes the problems locally for you? If so, please submit a new copy of the theme and I'll update it in the next release.

Also available in: Atom PDF