Project

General

Profile

Bug #4476

Roma theme for JITP - site doesn't load when slider is enabled

Added by Boone Gorges over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Themes
Target version:
Start date:
2015-08-24
Due date:
% Done:

0%

Estimated time:

Description

Original email report from Laura:

I had completely forgotten that there was an issue with the Roma theme that I had to fix when I was making the mockup on the social paper multisite. When the slider option is selected and the selection is saved, the website no longer loads. I think there is an issue with what is being called. I don't quite remember how this issue was resolved, but Keith Miyake and I were able to figure it out. I'm attaching the index.php file to this email.

At this point, I am going to deselect the slider option so that I can work on other portions of the site. Please let me know if you are able to help me figure this out (maybe just replacing the index.php file in the theme folder will be an easy fix?) and if you need me to stop working on the site for a while and re-select the slider option so that you can see what I am talking about. I appreciate any and all help that you can offer, and apologize for any inconvenience that is caused by this urgent request.

Laura, I'm looking into this right now.

index.php (3.73 KB) index.php Boone Gorges, 2015-08-24 01:24 PM

History

#1 Updated by Boone Gorges over 3 years ago

  • Private changed from Yes to No

#2 Updated by Laura Kane over 3 years ago

Thanks, Boone. I think I remember how to fix this issue - there is a plugin in the theme folder that needs to be installed along with all of the theme files: iw-framework plugin. The slider calls this plugin.

#3 Updated by Boone Gorges over 3 years ago

Thanks, Laura. Can you please tell me exactly how to reproduce the problem? Where do I set up the slider - in wp-admin > Appearance > Customize? What settings do I choose?

#4 Updated by Laura Kane over 3 years ago

Sure:

Roma Options -> Home Page Options -> Show Slider: ON

Then re-load the website. It won't load anything.

#5 Updated by Boone Gorges over 3 years ago

  • Status changed from New to Testing Required

I verified that the iw-framework plugin is the source of the issue. I added it to the Commons in https://github.com/cuny-academic-commons/cac/commit/ed6ed90ecdd551929a5867953d7823d1498cfb12 and deployed it to the production site as a hotfix. Laura, can you please verify that it's solved the slider problem for you?

The index.php file you attached appears to be unrelated. If you are having problems with category exclusion in the featured posts area - which is, I gather, what's happening in the modified index.php - let's talk about it in a separate ticket.

#6 Updated by Laura Kane over 3 years ago

Yes! It totally worked. Thank you! The index.php files is unrelated, but yes, I am having an issue with posts on the front page. I'll start another ticket.

Thank you so much for everything. I know I am posting a lot of issues with urgency, and I really appreciate all the help!

#7 Updated by Boone Gorges over 3 years ago

  • Category name set to WordPress Themes
  • Status changed from Testing Required to Resolved
  • Target version set to 1.8.9

Glad it's working!

Also available in: Atom PDF