Project

General

Profile

Bug #4485

Some content not updating on Prelude15 Site

Added by Alex Hills over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2015-08-24
Due date:
% Done:

0%

Estimated time:

Description

Hi, Boone,

I've noticed a weird issue where when I add new content to the Prelude15 site, it does not appear on the front-end. I've been able to edit content already on it but not add new content. It's saved in the admin, just not displayed on the front-end. Is is possible that there is some sort of caching turned on that could be effecting the site?

Thanks,
Alex

History

#1 Updated by Alex Hills over 3 years ago

Update: the content is now appearing on the site. It just seemed to take a while for it to be reflected on the front-end. Do you think that this might be a caching thing?

Thanks,
Alex

#2 Updated by Boone Gorges over 3 years ago

  • Category name set to WordPress (misc)
  • Status changed from New to Rejected

Hi Alex,

Ah, I was just opening this ticket to start diagnosis. Yes, it's almost certainly related to the caching layer we've got on the Commons. WordPress ought to purge your front-page cache when you add content. One of the following two things must be happening: (a) you're loading content on the front end in an abnormal way, which would somehow bypass WordPress's "latest posts" check, or (b) some combination of plugins/themes on your site is preventing the cache from being invalidated when publishing new content. These kinds of bugs are generally very hard to pin down, as cache invalidation problems are often hard to reproduce regularly.

I'm guessing that something happened elsewhere on your site that cleared the necessary caches while we slept :)

If the problem persists in the future, please reopen this ticket (or open a new one) with as many details as you can provide about how to reproduce. I can then dig in to try to find the issue. Since things are working OK at the moment, I won't take the time to do it today.

Thanks!

#3 Updated by Alex Hills over 3 years ago

Hi, Boone,

We've been experiencing a few issues that I think are related to this. First, to reply to your previous comments, yes, it's possible that using the Custom Post Types and Advanced Custom Fields plugins leads to not triggering a cache clear since most if not all of the content that it being added is using one or both of these plugins, not the usual post content field.

The issues that we've been experiencing lately have to do with updating content that has already been published. We attempted to update a custom gallery on the page Splash by removing two images and adding three new ones. When we updated the post the gallery reverted to the two old images. I was unable to update this gallery in any way—I could not remove the images and update and I could not add new images and update.

As a work-around, I created a new page and entered all of the desired content. This time when I published the page, the content did "stick" and could be seen in the admin. However, the images in the gallery do not appear on the page. Instead, I'm seeing this:

style="background-image: url(4)"

instead of this:

style="background-image: url(http://preludenyc.org/files/2015/08/Splash-Page-Background-3-Photo-by-Kelly-Stuart.jpg);"

Is there any way to removed this site from the cache process until we have entered all of our content? Or do you know of anything that I could try to trigger a cache clear.

Thanks,
Alex

#4 Updated by Boone Gorges over 3 years ago

  • Status changed from Rejected to Testing Required
  • Target version set to Not tracked

Hi Alex - Sorry you're continuing to have troubles.

I put a hack into place that bypasses the persistent object cache for the preludenyc15 site. As we guessed, this appears to be fixing the problems. Can you verify?

It looks like this is probably a bug in either ACF or the CPT plugin you're using. It's hard to know without more details about how to reproduce. If I had reliable steps to reproduce, I could probably fairly easily find the bug, and send a patch upstream - but reproducing is often the hardest part :)

For the purposes of your site, since most things will be static after you've finished setting up, it's probably good enough to blacklist you from the cache for the time being. Let me know when we can remove the cache block.

Ray, I've added you to the ticket as an FYI. In our wp-content/object-cache.php dropin (which is untracked because it will break local checkouts without APC - probably worth a WP ticket to figure out a better way to handle this ;) ), I added a blacklist of site IDs in `wp_cache_get()`. It's a pretty lousy hack, but should be OK for now. Let me know if you have thoughts about how to approach this differently.

#5 Updated by Alex Hills over 3 years ago

Thanks for making an exception here, Boone. It looks like updates are now happening as expected. I've been making some slight changes to the theme based on feedback from Segal. I plan on having the next version completed tonight. Will that be enough time for it to make it into the next upload?

Thanks again,
Alex

#6 Updated by Boone Gorges over 3 years ago

Yes, I'll probably release tomorrow afternoon. If you've got your stuff to me tonight, we should be good.

#7 Updated by Boone Gorges about 3 years ago

  • Status changed from Testing Required to Resolved

Also available in: Atom PDF