Project

General

Profile

Bug #4677

CDEV Authentication

Added by Stephen Real about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
cdev.gc.cuny.edu
Target version:
Start date:
2015-09-27
Due date:
% Done:

0%

Estimated time:

Description

After clearing the cache in Firefox, I type cdev.gc.cuny.edu in to the address bar. I see shot1.png attached. This prompt rejects my cdev credentials, but does accept cdev/community. After which I get shot2.png attached. I can then hit Cancel and go to the upper right corner, click login and enter my credentials to login once and for all (see shot3.png).

If I hit Cancel in response to the first pop up, I get shot4.png (not authorized).

It seems to me that the other browsers I use (Safari and Chrome) may behave ever so slightly differently, but I will save all the screen captures for another day.

Shot1.png (101 KB) Shot1.png Stephen Real, 2015-09-27 07:12 PM
shot2.png (122 KB) shot2.png Stephen Real, 2015-09-27 07:12 PM
shot3.png (164 KB) shot3.png Stephen Real, 2015-09-27 07:12 PM
shot4.png (65.3 KB) shot4.png Stephen Real, 2015-09-27 07:12 PM

History

#1 Updated by Boone Gorges about 6 years ago

  • Category name set to cdev.gc.cuny.edu
  • Target version set to Not tracked

Thanks, Stephen. I've reached out to IT for help with this.

#2 Updated by Boone Gorges about 6 years ago

  • Status changed from New to Testing Required
  • Assignee set to Stephen Real

I confirmed with IT that this was being caused by ModSecurity false positives on cdev. We've disabled ModSecurity there for the time being. Could you please retest?

#3 Updated by Stephen Real about 6 years ago

In Safari somehow, when I type cdev.gc.cuny.edu I land on the page shown in shot2.png and I can login with my credentials by clicking into the login link at the top right corner of the page. When I enter the same address in Chrome or Firefox I still get the page shown in shot1.png and my credentials still do not work, but cdev/community does work to get me to shot2.png.

#4 Updated by Boone Gorges about 6 years ago

Could you try clearing your browser cache in the problematic browsers? I don't see the problem anymore on my end, so I wonder if what you're seeing is a lingering issue.

#5 Updated by Stephen Real about 6 years ago

Boone,
I cleared the cache on both browsers and the symptoms did not change. I will ask if any others on the community team can replicate the experience I am having.

#6 Updated by Stephen Real about 6 years ago

  • Status changed from Testing Required to Resolved

I think we can mark this one resolved.

Also available in: Atom PDF