Project

General

Profile

Support #4713

academia theme issues

Added by scott voth over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Themes
Target version:
Start date:
2015-09-30
Due date:
% Done:

0%

Estimated time:

Description

From member Tsubasa Berg:

"I recently created a new site<http://kctldiversefaculty.commons.gc.cuny.edu/> on Academic Commons, and am trying to figure out how to get the following two things done:

1. In the mobile view, there is a black bar on the top of the page that overlaps with the header title/logo. I'm trying to add extra padding on the top to move the title/logo down on the page using CSS. I tried a couple of things, but no luck.
2. I'm also trying to set a logo image in the header (without removing the title/subtitle line). The theme allows me to add "Logo" in the "Customization," but for some reason, it's not showing up on the header."

I set up a site using that theme - I think that issue #1 may be related to the length of the subtitle that throws off the format. My subtitle was shorter and worked fine. Is there a CSS workaround?
For issue #2 - I see (like Tsubasa) that the theme does not seem to respond to logo changes.

Thanks.

History

#1 Updated by Boone Gorges over 3 years ago

  • Category name set to WordPress Themes
  • Status changed from New to Assigned
  • Assignee set to Daniel Jones
  • Target version set to Not tracked

Dan, could you please have a look at these issues?

#3 Updated by Daniel Jones over 3 years ago

Issue #1 has a pretty easy fix, just copying over some CSS from the bp_nelo theme to add padding to the top of the header when browser width gets below 650px. I imagine that lots of themes would have this issue is they weren't designed with the admin bar in mind.

Issue #2 is pretty strange: if I upload a really large image, it does show up as the logo. Smaller images don't show up though. It looks like it has something to do with the fact that the theme's test for whether or not it has a logo set includes tests for whether or not the logo file has width and height dimensions set, and the larger images pass that test but the smaller ones don't. They also do a very weird manual database query to find the attachment ID of the image, which looks like it just doesn't work. Don't know why things work out fine for the larger images though. What I did as a short-term fix was just remove all the tests, etc. for image dimensions and change it so that if the user uploads a logo image, the header displays it. Seems to work fine, although it isn't responsive: the image is the size the user uploads it as. That's how it seems to work in the original code too though.

Also - the theme is set up so that if there's a logo image, it takes the place of the title instead of going along with it. In my experience that's pretty standard.

I think my basic suggestion would be to use a different theme, because these problems are with the theme itself and not anything on our end as far as I can tell.

#4 Updated by Boone Gorges about 3 years ago

  • Status changed from Assigned to Resolved

Scott, I'm going to close this ticket on the basis of Dan's advice above. Please feel free to reopen if the user continues to have problems.

Also available in: Atom PDF