Project

General

Profile

Bug #4728

Quick link field displays alternate address on profile page.

Added by Raffi Khatchadourian almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Commons Profile
Target version:
Start date:
2015-10-02
Due date:
% Done:

0%

Estimated time:

Description

My quick link URL is http://cuny.is/khatchad. However, on my [[profile page]https://commons.gc.cuny.edu/members/khatchad/], it shows http://cuny.is/khatchad2. I was expecting http://cuny.is/khatchad.

History

#1 Updated by Boone Gorges almost 4 years ago

  • Target version set to Not tracked

They both appear to be valid links. How did you create them?

#2 Updated by Raffi Khatchadourian almost 4 years ago

Yes, they are both valid. I don't know how http://cuny.is/khatchad2 came around but http://cuny.is/khatchad was created when I created my profile.

#3 Updated by Raffi Khatchadourian almost 4 years ago

Boone Gorges wrote:

They both appear to be valid links. How did you create them?

Ah, I should mention that I can't change it back to http://cuny.is/khatchad.

#4 Updated by Boone Gorges almost 4 years ago

Thanks, Raffi. It's odd that you'd have two, but I'm guessing that it's due to the second problem: that you can't "change it back". I see both URLs in cuny.is, and they both point to the same commons.gc.cuny.edu, although one has a trailing slash and the other does not. The code is designed to detect these sorts of equivalences, and allow you to change your quick link to an existing one if the existing one is already pointing to your profile. But it sounds like this is not working as designed.

Can you give more details about the "can't change it back" bit? When editing your profile, if you type 'khatchad' into the Quick Link field, there should be an AJAX availability test. It'll tell you whether the URL is available. What is it telling you? What happens when you save your profile?

#5 Updated by Raffi Khatchadourian almost 4 years ago

Boone Gorges wrote:

Thanks, Raffi. It's odd that you'd have two, but I'm guessing that it's due to the second problem: that you can't "change it back". I see both URLs in cuny.is, and they both point to the same commons.gc.cuny.edu, although one has a trailing slash and the other does not. The code is designed to detect these sorts of equivalences, and allow you to change your quick link to an existing one if the existing one is already pointing to your profile. But it sounds like this is not working as designed.

Can you give more details about the "can't change it back" bit? When editing your profile, if you type 'khatchad' into the Quick Link field, there should be an AJAX availability test. It'll tell you whether the URL is available. What is it telling you? What happens when you save your profile?

Hi Boone,

I looked into this a bit further. I was actually able to change it back to khatchad. I just had to wait for the AJAX control to kick in. I always thought this wasn't working. I guess I'm just too fast. Thanks for your help!

#6 Updated by Boone Gorges almost 4 years ago

  • Status changed from New to Resolved

Excellent - thanks for the update.

Looking back, it looks like there was a brief period where the duplicate name check wasn't working properly. It's likely that your khatchad2 URL was created during this time, making it an isolated incident that shouldn't repeat itself. Since you've managed to change back to your preferred quick link, I think there's nothing more to do here.

Also available in: Atom PDF