Project

General

Profile

Bug #478

bp-default sidebar template is loading incorrectly

Added by Boone Gorges over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2010-12-13
Due date:
% Done:

0%

Estimated time:

Description

Since BP 1.2, the default BP theme has had a sidebar that allows things like login on any page, groups/members widgets, and sitewide message display. The Commons BP theme was designed before this version of the BP default theme, and does not use this sidebar. Yet the sidebar was getting loaded in the background of just about every page. In most cases, this is harmless, since the styling ensured that it was hidden. But on some BP pages, small parts of the hidden sidebar would creep onto the main page.

The "right" way to fix this is to remove all the get_sidebar() references in our BP templates, but this is a lot of work, and will mean overriding default templates for no good reason. A better solution for now is to provide a sidebar.php in the child theme and make it empty.

History

Also available in: Atom PDF