Project

General

Profile

Bug #5184

Problem linking SP to a group

Added by Marilyn Weber almost 6 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
Social Paper
Target version:
-
Start date:
2016-01-29
Due date:
% Done:

0%

Estimated time:

Description

Yesterday I created a paper, then a group. Today, I went to link the paper ("Marilyn’s Fakertation") to the group, but the group (Oakes Dissertation Seminar) did not appear. I thought the problem was that the group hadn't been created when I saved the draft. So I then created a new SP (just "Fakertation") but again the group does not appear. I've attached a screenshot showing I can see other groups, but not the "Oakes Dissertation Seminar"

Should I ask Sarah and Scott to try this as well?

History

#1 Updated by Boone Gorges almost 6 years ago

  • Category name set to Social Paper
  • Assignee set to Boone Gorges
  • Target version set to 1.9.6

Marilyn, could you attach that screenshot please? It looks like you forgot.

It's possible that this is a caching issue. A user's list of groups is cached fairly heavily by SP, and it could be that the process of creating a new group doesn't bust this cache properly. If anyone could verify, it'd be helpful, otherwise I'll try to take a look later today when I do the release.

#2 Updated by Boone Gorges almost 6 years ago

  • Status changed from New to Reporter Feedback
  • Target version deleted (1.9.6)

I just did some testing to see if I could reproduce this problem, and I found I wasn't able to. Newly created groups show up in the dropdown, as expected. (The caching hypothesis I laid out above is not correct - SP caches group memberships, but in a way that doesn't persist between pageloads.)

I'm going to remove this ticket from the milestone while we try to get it reproduced. Marilyn, please let me know if you're able to reproduce using a different computer/browser setup.

#3 Updated by Boone Gorges almost 6 years ago

Hi Marilyn - Any chance reproducing this problem elsewhere?

#4 Updated by Boone Gorges almost 6 years ago

  • Status changed from Reporter Feedback to Rejected

I'm going to close this ticket due to the lack of steps to reproduce. Marilyn, if you're still having the trouble, please do feel free to reopen with some details. Thanks!

Also available in: Atom PDF