Project

General

Profile

Bug #5359

Social Paper Comment Bug

Added by Paige Dupont about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Social Paper
Target version:
Start date:
2016-03-23
Due date:
% Done:

0%

Estimated time:

Description

I've been trying to add a comment to a paper but I keep getting a message saying there is an error and the comment cannot be added. I refreshed the page and tried to add the comment again and then I get the message, "duplicate comment detected, you've already added this." So I refreshed the page again to check the paper but there are no comments to be found.

So I then went to my papers page and it shows that there are comments. I've attached a photo for you to see the only place I can see that I've gotten comments.

However, there are no comments to be found on the paper itself. Please help!

Comments on SP.png (39.9 KB) Comments on SP.png Paige Dupont, 2016-03-23 03:47 PM

History

#1 Updated by Boone Gorges about 3 years ago

Hi Paige - I'm not able to reproduce this on a sample paper, and I couldn't find the "I am the best writer in the world" paper from the screenshot (sadly! I was looking forward to reading it). Assuming you deleted it, could you set up another one and link to it here, so that I can test on a paper where the problem is predictably reproducible?

#2 Updated by Paige Dupont about 3 years ago

Yeah, no problem, it was a private paper but it should have worked since I added the reader to the paper. I was using this test account:

login: prattone
password: prattux

Feel free to login and try it with this account. I tried to add you as a reader but the closest I found to you was, Boone test 401. In the off chance that wasn't you, I wanted to spare Boone 401 the glory that is "the best writer in the world."

Here's a link to the paper if you are logged in as prattone: https://commons.gc.cuny.edu/papers/user-testing-for-cuny/

Thanks Boone!

#3 Updated by Boone Gorges about 3 years ago

  • Category name set to Social Paper
  • Target version set to 1.9.12

Thanks for the details, Paige!

It turns out that your comments were being flagged as spam. There are two bugs here:

1. Comment counts in the Paper Directory should not reflect non-approved comments
2. Comments from logged-in users should not be subject to spam filters

I'll work on these for the next release.

Also available in: Atom PDF