Project

General

Profile

Bug #5445

Private group question

Added by Matt Gold almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Start date:
2016-04-13
Due date:
% Done:

0%

Estimated time:

Description

Hi Ray,

I edited the description on a private (not hidden) group and wanted to see what it would look like to non-members of that group.

When I visited the group homepage as a non-logged in user, I received a log-in page - http://nycdh.org/wp-login.php?redirect_to=http%3A%2F%2Fnycdh.org%2Fgroups%2Fnycdh-steering-group%2F&action=bpnoaccess

Is this expected behavior? And has this changed at all recently I had thought it would show a group description (but not group files/forum etc) rather than a log in page

History

#1 Updated by Raymond Hoh almost 6 years ago

This is not expected behavior.

This is due to CBOX modifying the group homepage to use the forum page. However, since non-logged-in users cannot access the private group forum, BP is asking users to login to access the group forum.

What we should be doing is modifying private groups to use the group default homepage instead of the forum for non-logged-in users.

Will fix this for CBOX.

#2 Updated by Matt Gold almost 6 years ago

Excellent -- thanks, Ray. I guess a short-term fix on the NYCDH site would be for me to restore the default homepage

#3 Updated by Matt Gold almost 6 years ago

Confirming that the short-term fix worked

#4 Updated by Raymond Hoh almost 6 years ago

  • Status changed from Assigned to Resolved

I've added a fix for this on the CBOX repo.

Also available in: Atom PDF