Project

General

Profile

Support #5776

Displaying CartoDB Maps in Commons

Added by Chris Meatto almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2016-07-07
Due date:
% Done:

0%

Estimated time:

Description

I am currently working on my MALS thesis at the Grad Center, and am trying to embed maps that I created using CartoDB into my Commons site. However, when I copy and paste the embed link into my pages and/or posts, nothing shows up.

The documentation online seems to indicate that this process works for Wordpress.com sites, but I couldn't figure out how to do so in the Commons.

Last spring, I requested and was granted adding the plugin CartoPress to the Commons, but this seems to take data from Wordpress and map it in CartoDB, and not the other way around.

Any help that you could provide in publishing these maps would be greatly appreciated! And if there is any more information that I could provide to help move things forward, please let me know.

Thanks so much!


Related issues

Related to CUNY Academic Commons - Support #8095: iframe the two Cartodb maps?Rejected2017-05-04

History

#1 Updated by Boone Gorges almost 6 years ago

  • Status changed from New to Reporter Feedback
  • Target version set to Not tracked

It appears that Jetpack has support for CartoDB embeds. https://jetpack.com/support/shortcode-embeds/

Chris, could you try activating the Jetpack plugin on your site? Once you've done that, paste the CartoDB URL (not a hyperlink, and not the embed code - just the URL) on its own line in the editor. Embedding should be automatic.

#2 Updated by Chris Meatto almost 6 years ago

Thanks for the help, Boone. I activated Jetpack and followed your steps + the documentation on Wordpress, and still am not getting the maps to display. When I enter the URL (not hyperlink or embed code) into a the Visual editor for a new post or page, no map shows up. Just the URL itself. The documentation also notes that the map should preview live in the editor, but that's not happening for me either. Sorry that I can't quite figure this out.

Chris

Boone Gorges wrote:

It appears that Jetpack has support for CartoDB embeds. https://jetpack.com/support/shortcode-embeds/

Chris, could you try activating the Jetpack plugin on your site? Once you've done that, paste the CartoDB URL (not a hyperlink, and not the embed code - just the URL) on its own line in the editor. Embedding should be automatic.

#3 Updated by Boone Gorges almost 6 years ago

Are you able to share the URL of one of the CartoDB maps you're trying to embed? It appears that CartoDB may recently have changed its URL structure in such a way that the Jetpack embedding tool broke.

#4 Updated by Chris Meatto almost 6 years ago

Thanks for the quick response! Here is one of the maps, with 2 different URLs just in case:

https://clmeatto.carto.com/viz/1d521b88-f8ee-11e5-b61c-0e8c56e2ffdb/map

https://clmeatto.carto.com/viz/1d521b88-f8ee-11e5-b61c-0e8c56e2ffdb/public_map

Boone Gorges wrote:

Are you able to share the URL of one of the CartoDB maps you're trying to embed? It appears that CartoDB may recently have changed its URL structure in such a way that the Jetpack embedding tool broke.

#5 Updated by Boone Gorges almost 6 years ago

  • Category name set to WordPress Plugins
  • Status changed from Reporter Feedback to Resolved
  • Assignee set to Boone Gorges
  • Target version changed from Not tracked to 1.9.20

Thanks, Chris. I've confirmed that this is a bug in Jetpack, due to the change from cartodb.com to carto.com URLs.

I've opened a pull request to fix the issue in Jetpack: https://github.com/Automattic/jetpack/pull/4349

Until it's merged, I've put a temporary fix in place for the Commons. These embeds should start working again after the deployment on July 11. https://github.com/cuny-academic-commons/cac/commit/62060bbd848242951074400ccd6b9ee9b5f383ec

#6 Updated by Chris Meatto almost 6 years ago

Excellent--thanks so much, Boone. The fix you put into place works on my end!

Chris

#7 Updated by Boone Gorges about 5 years ago

Also available in: Atom PDF