Project

General

Profile

Feature #6316

Replacing Issue 6122 -- Plugins to Support Teaching

Added by Luke Waltzer over 2 years ago. Updated about 1 month ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2016-10-14
Due date:
% Done:

0%

Estimated time:

Description

Feature #6122: Plugins to Support Teaching
Author: Luke Waltzer
Status: New
Priority: Normal
Assignee:
Category:
Target version:
In preparation for the Faculty Teaching Fellows project, exploring plugins we might add to enhance the teaching functionality of the space.

What are your thoughts about...

@Boone's WP Grade Comments
https://wordpress.org/plugins/wp-grade-comments/

Here's a relatively new gradebook plugin... maybe we can give a test run on dev?
https://wordpress.org/plugins/an-gradebook/

Reckoning?
https://wordpress.org/plugins/reckoning/

Also, should we explore ways to start tagging metadata to sites for record keeping purposes? Here's the plugin we used on B@B for that purposes, which may be overkill for the Commons (and has options hardcoded into it).
https://github.com/shawnrice/wp-network-blog-metadata

Michael, Matt-- other thoughts?

Oct 4 (10 days ago)
Issue #6122 has been updated by Matt Gold.
I think this looks great. It would be good to round a list of other, existing teaching-related plugins so that we can pull togehter a "Teaching on the Commons" hub of some kind. Off the top of my head:

-- Social Paper (for paper review/feedback)
-- CommentPress (for review/feedback)
-- Jetpack (for CartoDB map embedding)
-- DiRT Tools (for using with groups to see who is using what tool)

others?

Oct 12 (2 days ago)
Issue #6122 has been updated by Michael Smith.
Recently Registered - adds a sortable column to the users list of a site, I use this in a course blog that continues to add authors semester after semester.
Restrict Author Posting - allows admin to have authors post to particular categories (for example semester to semester categories) and works well in combination with the list category posts plugin already installed
Top Commentators Widget - we may already have something like this
Black Studio TinyMCE Widget - Allows for the "kitchen sink" in a widget editor. Nice for those don't know HTML and as an alternative to the Text widget.

Oct 12 (2 days ago)
Issue #6122 has been updated by Matt Gold.
Luke/Michael: perhaps we could separate out the plugins that need testing/further thought and those that can/should be added more or less immediately. If there are any plugins that look like they might be good to add in the short term, please create a new ticket and we can use this one for ongoing discussion.


Related issues

Related to CUNY Academic Commons - Feature #9942: Plugin PackagesResolved2018-06-15

History

#1 Updated by Raymond Hoh about 1 month ago

#2 Updated by Raymond Hoh about 1 month ago

  • Status changed from New to Duplicate

Duplicate of #9942.

Also available in: Atom PDF