Project

General

Profile

Actions

Bug #7683

closed

Posts from Group Sites Appear Twice in the Recent Posts widget on the Commons Homepage

Added by Luke Waltzer over 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Blogs (BuddyPress)
Target version:
Start date:
2017-02-15
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

If a new post is published to a site attached to a group, the post appears twice in the Recent Posts widget on the homepage, eating up real estate. Might we exclude the notification from the group?


Files

Actions #1

Updated by Boone Gorges over 7 years ago

  • Category name set to Blogs (BuddyPress)
  • Assignee set to Boone Gorges
  • Target version set to 1.10.11

This shouldn't be happening, and I can't reproduce it in some basic tests. Writing a blog post creates a new_blog_post activity item; if bp-groupblog detects that the activity item is associated with a groupblog post, it updates the activity item to be new_groupblog_post. In this case, there's both a new_blog_post and new_groupblog_post activity item. I'll dig a bit more in the upcoming days to see if I can figure out why this might happen in some cases.

Actions #2

Updated by Boone Gorges about 7 years ago

  • Target version changed from 1.10.11 to 1.10.12
Actions #3

Updated by Boone Gorges about 7 years ago

  • Target version changed from 1.10.12 to 1.10.13
Actions #4

Updated by Boone Gorges about 7 years ago

  • Status changed from New to Resolved

I tracked down the issue. It has to do with post edits. When a groupblog post is edited, the groupblog plugin attempts to locate and update the existing "new_groupblog_post" activity item instead of creating a new one. There's a filter that allows this matching process to be skipped, which we'd activated before BP's site-activity system was rewritten in BP 2.2 or so. I've rolled back our use of this filter, so that bp-groupblog can run its matching properly. This prevents duplicates on post edit. https://github.com/cuny-academic-commons/cac/commit/44973c0b679da4f602f7ecf959d8c410c2a26351

Actions

Also available in: Atom PDF