Project

General

Profile

Support #7836

missing Social Paper

Added by Marilyn Weber over 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
Social Paper
Target version:
Start date:
2017-03-27
Due date:
% Done:

0%

Estimated time:

Description

User Janae Calderon reports that she created a private Social Paper on March 20th called FV1 (for her EDR 605 class) "and now when I click on my paper it loads another classmates paper. However in the drop screen when it says I uploaded three days ago or however many days prior and it shows a snippet of the paper it is the paper I submitted but I can not find the original paper I wrote." She later added: "I didn't upload it using word or anything I typed it right onto the page. It's just so weird because when I log in it shows I uploaded it 7days ago and has the beginning of my paper and then when I click on the name FV1 it shows my classmates paper"

Matt writes "I'm wondering if SP had a bug where there were two papers with same name, and it might not have handled that well. SP should have draft versions available, so Boone might be able to recover the text if there was an autosave"

Let me know if you need more information.

History

#1 Updated by Boone Gorges over 2 years ago

  • Status changed from New to Reporter Feedback

Somehow, two different papers ended up with the same slug: 'fv1'. When visiting commons.gc.cuny.edu/papers/fv1, WP didn't know which paper was being requested, so it was returning the first one it could find.

I've fixed the issue in the database, so that it should be possible for Janae to visit her paper at https://commons.gc.cuny.edu/papers/fv1-9/.

SP attempts to prevent papers from being created with duplicate slugs. When you enter the title of your paper, SP will suggest a slug that is known to be unique (such as fv1-10). If you manually change that slug to one that's already taken, it'll force it back to something unique. So I'm not sure how the duplicate could have happened in this case. Perhaps there's an edge case that occurs when users are creating papers at precisely the same time, or when a paper draft is created with a certain slug, and another paper is published with that slug before the first one can be switched to Published. Marilyn, after you've verified that Janae can access her paper, could you ask for more details about how she create the paper in the first place? Was it during an in-class activity, when others would've been working at just the same time? Did she manually modify the URL of the paper when creating/editing it? Did she create it in Draft status first, and publish it only later?

#2 Updated by Marilyn Weber over 2 years ago

She can access it now. She replied "I typed it at home just under the Create a new paper. I typed it right onto the website as FV1 because that was what we needed to name the assignment. When I was done I saved it as private to my group EDR 605 on March20. The change had to have occurred after March 21 because that was when the other student posted his paper. I did not save it as a draft and then publish."

#3 Updated by Boone Gorges over 2 years ago

  • Status changed from Reporter Feedback to Resolved
  • Target version set to Not tracked

Thanks for confirming and for collecting the additional information, Marilyn. It sounds like Janae had the slug first, but the other user managed to take it somehow.

Since I'm unable to reproduce this in testing, I'm going to mark the ticket as resolved. If the problem occurs again, we'll do a deeper investigation to find out in what circumstances it may be possible to create duplicate slugs.

#4 Updated by Marilyn Weber over 2 years ago

  • Status changed from Resolved to New

Apparently this is happening again, for the same group.

Professor Jennifer Van Allen reports:

Hi! I'm a professor at Lehman College using CUNY Commons to facilitate peer feedback in one of my classes this semester (Group name _ EDR 605 Spring 2017 Van Allen). We are using Papers to do so. I noticed that one of my students (Arleni Ulloa) uploaded a paper (LRV2) three days ago and it shows up in group activity, but does not show up in Papers. If you follow the link on the group activity it goes to page not found. Was there an error during the upload? Thanks for any assistance you can provide.

https://commons.gc.cuny.edu/groups/edr-605-spring-2017-503822456/papers/

#5 Updated by Boone Gorges over 2 years ago

  • Status changed from New to Reporter Feedback

I'm unable to reproduce the issue. As a member of the group, I'm able to see the item in the activity stream, and click through to the paper's URL https://commons.gc.cuny.edu/papers/lrv-2. I'm also able to see it in the group's Papers tab (currently on the second page). Marilyn, I see that you're a member of the group. Can you confirm the behavior in one direction or another?

#6 Updated by Boone Gorges almost 2 years ago

  • Status changed from Reporter Feedback to Resolved

I'm assuming the class where this was an issue is now over, so this doesn't need further investigation.

Also available in: Atom PDF