Project

General

Profile

Actions

Feature #7910

closed

Syncing User Email between Commons Profile and Site

Added by Luke Waltzer almost 6 years ago. Updated over 3 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2017-04-04
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

A user reports that he changed the email in his Commons profile, but his email on his site remains the one he registered with. These should sync, right?

I've confirmed the report.

User -- https://commons.gc.cuny.edu/members/anthony7mus/?commons-profile=1.
Site -- https://msh334spring2017.commons.gc.cuny.edu/
User profile on site -- https://msh334spring2017.commons.gc.cuny.edu/wp-admin/user-edit.php?user_id=8420&wp_http_referer=%2Fwp-admin%2Fusers.php

Actions #1

Updated by Boone Gorges almost 6 years ago

  • Tracker changed from Bug to Feature
  • Status changed from New to Reporter Feedback

The email address on the users.php screen is the canonical email associated with a user's account. It's what's used when the site sends emails, and users may use the address to log into the site. It can be changed on the Settings portion of your profile.

The email address on a user's Commons Profile is a public-facing piece of profile data.

The separation is by design: one may want a different email address displayed on the profile than what's actually used for site business.

If we want to keep the separation, perhaps we can do a better job labeling the public profile field - "Public Email" or something like that. Or, if we want the public and private to be merged/synced, we can do so, but it might be worth notifying users about it.

Actions #2

Updated by Luke Waltzer almost 6 years ago

Ah... I should have picked up on this. Thanks. We can discuss.

Actions #3

Updated by Boone Gorges almost 6 years ago

  • Assignee set to Luke Waltzer
  • Target version set to Future release
Actions #4

Updated by Luke Waltzer over 3 years ago

  • Status changed from Reporter Feedback to Rejected
Actions

Also available in: Atom PDF