Project

General

Profile

Bug #8131

Newsletters plug-in

Added by Marilyn Weber over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2017-05-11
Due date:
% Done:

0%

Estimated time:

Description

Rukshana Jalil has been using the Newsletters plug-in for her site https://americanstudiescp.commons.gc.cuny.edu/, but is isn't working. I see that there's an update, but clicking download takes me to a page where a username and password is required - https://tribulant.com/users/login?from=/downloads/

I'm now an admin on the site. Should I enter my own username and password?

Screenshot_2017-05-11_12-56-41.png (56.5 KB) Screenshot_2017-05-11_12-56-41.png Boone Gorges, 2017-05-11 01:58 PM
After SE.PNG (67.8 KB) After SE.PNG Marilyn Weber, 2017-05-11 02:16 PM
Before SE.PNG (116 KB) Before SE.PNG Marilyn Weber, 2017-05-11 02:16 PM

History

#1 Updated by Boone Gorges over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Target version set to 1.10.19

Can I get more information about how the plugin is not working?

We stopped updating the plugin some time ago because the plugin changed its slug, which means that we would have to crawl through all sites to switch them to the new plugin. I'll do that for this release.

(Marilyn, don't ever enter your Commons credentials into a site whose URL is not *.commons.gc.cuny.edu, or a domain that you know to be mapped to the Commons.)

#2 Updated by Marilyn Weber over 4 years ago

She wrote "I was able to create a newsletter this morning, but when I wanted to preview it, the page did not load." I tried as well. I just get a blank page when I click on Send/Edit.

She reports that she'd be fine using a different plug-in with the same functions. Any suggestions?

(Don't worry! I haven't and never would.)

#3 Updated by Boone Gorges over 4 years ago

I've attached a screenshot of what I see when I try loading the 'Save/Edit' section of one of these newsletters. Is this what you mean by "blank page", or are you seeing something different?

What I'm seeing appears to be a timeout. I haven't dug into it any deeper than that. I'm going to upgrade the plugin as part of today's release, and I'll test again at that time. If there's still an issue, I guess I'll try to see what is going on.

#4 Updated by Marilyn Weber over 4 years ago

No, I've attached the "save/Edit" before and after screens now. If the upgrade works today, great. If not, she'll try something else.

#5 Updated by Boone Gorges over 4 years ago

  • Target version changed from 1.10.19 to 1.11.1

The plugin is updated but the page is still not loading. I'll look more closely into the problem when I've completed my release procedures.

#6 Updated by Boone Gorges over 4 years ago

I've found the problematic line in the Newsletters plugin, but I'm not really sure of the root cause. When loading a Newsletters page, the plugin does the following:

set_time_limit( 0 )
. For some reason, this is causing Apache to time out on our server. I've tried debugging and researching the problem, but I haven't had any luck. For the time being, I'm commenting out the line, and the plugin works. It's a fix we'll have to reapply the next time the plugin updates.

Can you please verify that things are working now?

#7 Updated by Marilyn Weber over 4 years ago

Yes, all set!

#8 Updated by Boone Gorges over 4 years ago

  • Status changed from Assigned to Resolved
  • Target version changed from 1.11.1 to 1.11

Great, thanks! Moving this to 1.11, since the fix is in the repo.

Also available in: Atom PDF