Project

General

Profile

Bug #8977

Temporarily Unable to Bulk Invite to Groups

Added by Luke Waltzer over 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
Group Invitations
Target version:
Start date:
2017-12-04
Due date:
% Done:

0%

Estimated time:

Description

Ran into an issue sending invites via this group -- https://commons.gc.cuny.edu/groups/oer-faculty-fellows/invite-anyone/

Clicked the "Send Invites" button 10 times or more before browser performed an action (seems invites now went through). Using Chrome, screenshot attached.

One factor that might have contributed... curser was in the "search for members to invite" field due to an aborted addition.

History

#1 Updated by Boone Gorges over 1 year ago

Can you say more about what you noticed after you first clicked Send Invites? Do you recall whether the status bar indicated that the server was being contacted? Did you wait a certain amount of time between clicking Send Invites?

#2 Updated by Luke Waltzer over 1 year ago

No response from status bar. Waited a few seconds between each attempt. Then waited a full minute (looked at another tab and came back). Don't recall that I did anything specific before the click that worked, though.

#3 Updated by Boone Gorges over 1 year ago

Got it, thanks. I'll try to reproduce.

#4 Updated by Boone Gorges over 1 year ago

  • Category name set to Group Invitations
  • Assignee set to Boone Gorges
  • Target version set to 1.12.5

Played with this a bit and was not able to reproduce.

My current best guess is that a separate AJAX action was stalled in your browser, which blocked the clicking of the Send button. This could've been either an autocomplete request (you mentioned that the cursor was in the search input) or the request that takes place after selecting a member from the autocomplete list. This sort of timing issue is more likely to take place when there's latency in AJAX requests, and the autocomplete request is fairly slow by nature. If you happened to be testing at a time when the Commons was experiencing general slowness, it'd make this problem worse.

I'm wary of spending too much time making incremental improvements to this interface for the purposes of the Commons, since it'll be replaced by our new onboarding modal. But I'll bump it to the next milestone in the hopes of at least disabling the Send Invites button while other AJAX requests are in effect.

#5 Updated by Boone Gorges over 1 year ago

  • Target version changed from 1.12.5 to 1.12.6

#6 Updated by Boone Gorges over 1 year ago

  • Target version changed from 1.12.6 to 1.12.7

#7 Updated by Boone Gorges about 1 year ago

  • Target version changed from 1.12.7 to 1.12.8

#8 Updated by Boone Gorges about 1 year ago

  • Target version changed from 1.12.8 to 1.12.9

#9 Updated by Boone Gorges about 1 year ago

  • Status changed from New to Rejected

Closing this in anticipation of upcoming mods to onboarding process.

Also available in: Atom PDF