Project

General

Profile

Bug #100

Unclickable title links on group forum

Added by Matt Gold over 12 years ago. Updated over 12 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Upgrades
Target version:
-
Start date:
2009-12-03
Due date:
% Done:

0%

Estimated time:

Description

Hi Boone,

I was just looking at the online/blended learning group, and I found that I couldn't click on the titles of forum posts to view the posts themselves. Basically, there doesn't appear to be a way for me to look at the contents of this forum. (I was logged in when I visited).

Other issues:

the Latest forum topics list appears to include only public groups, not private/hidden groups of which one is a member

the forum search page returns a generic list of groups and puts search results at the bottom of the page, which is confusing

History

#1 Updated by Matt Gold over 12 years ago

  • Category name changed from BuddyPress (misc) to Upgrades

#2 Updated by Boone Gorges over 12 years ago

  • Status changed from Assigned to Reporter Feedback

The unclickable links were a CSS issue that is now fixed.

I'm pretty certain that the exclusion of private group forums under "recent forum posts" is part of BP core (either by design or because they haven't gotten around to making it more fine-grained yet). I just looked around for a few minutes in the core code and couldn't see at a glance what's causing private groups not to show. To fix it is far too big a job for right now. I'm going to put it in a separate ticket so that I can close this one.

I exchanged "Popular Group Forums" with "Latest Forum Topics" to address your final issue. Let me know if it's OK.

#3 Updated by Matt Gold over 12 years ago

  • Status changed from Reporter Feedback to Resolved

Nice work, Boone. The forum topics are now clickable for me, and the layout of the forums looks a lot better with Latest Forum Posts up top. I'm going to add two separate tickets for other small things that I see, but I'm going to close this one. Many thanks.

Also available in: Atom PDF