Project

General

Profile

Bug #10040

User doesn't see full list of themes

Added by Matt Gold about 3 years ago. Updated about 3 years ago.

Status:
Reporter Feedback
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2018-07-23
Due date:
% Done:

0%

Estimated time:

Description

When Jessica Murray, a CAC user, goes to the dashboard of her website on the Commons, she sees only 20 or so themes, even though we have 50-odd themes available. Luke and I are meeting her and she showed us what she is seeing.

Luke just advised her to do a hard-refresh, and that solved the problems, but it worries me a bit that she would have to do a hard refresh to see the full list of themes available. Boone, do you have a sense of what might be going on?

JM-Support-Details.pdf (2.45 KB) JM-Support-Details.pdf Jessica Murray, 2018-07-24 01:00 PM

History

#1 Updated by Boone Gorges about 3 years ago

Info about available themes is loaded into a JS variable at the time of page initialization. It's not fetched by AJAX.

It's hard to tell for sure without more information about what you were seeing, but from the number 20 I'm guessing that some other script on the page was breaking WP's theme "pagination". (It's not "pagination" in the sense that you go to a second page; but themes.php initializes the first 20 themes into the theme list at the time of page load, and does the next 20 once you've scrolled far enough.) You don't mention whether a soft refresh was attempted but didn't work, but if that's the case, it could be that the browser had previously cached a version of a plugin script (or something) that was causing a JS error on the page, which was late enough to allow the initial rendering of themes, but prevented the pagination method from running. A hard refresh would've cleared this cached broken script.

If this problem recurs, please collect debug information from the JavaScript console https://webmasters.stackexchange.com/questions/8525/how-do-i-open-the-javascript-console-in-different-browsers. If you're able to reliably trigger the error on a certain site, or by performing a certain series of actions, please share those details here.

#2 Updated by Boone Gorges about 3 years ago

  • Category name set to WordPress (misc)
  • Status changed from Assigned to Reporter Feedback
  • Target version set to Not tracked

#3 Updated by Jessica Murray about 3 years ago

A soft refresh works, but I noticed it only loads an additional 20 themes (I have to refresh when I scroll down to the bottom of the first 20, then scroll down and refresh again when those are loaded).

Here's the JS error

jquery.js?ver=1.12.4-1.13.6:3 [Violation] Added non-passive event listener to a scroll-blocking 'touchmove' event. Consider marking event handler as 'passive' to make the page more responsive. See https://www.chromestatus.com/feature/5745543795965952

#4 Updated by Boone Gorges about 3 years ago

Thanks, Jessica. That error message doesn't seem likely to be related.

Could you please give me a URL to see if I can reproduce myself?

#5 Updated by Jessica Murray about 3 years ago

It's on https://jtds.commons.gc.cuny.edu/wp-admin/themes.php. Do I need to add you as an administrator, or can you access it?

#6 Updated by Boone Gorges about 3 years ago

Nope, no need to add me.

I'm not able to reproduce on my machines. The issue could be linked to your specific setup. Could you please visit https://supportdetails.com/, then Export PDF and upload the pdf here?

#8 Updated by Boone Gorges about 3 years ago

Thanks, Jessica. I'm still not seeing the error, on a machine with a similar configuration. I also don't see the console error you've mentioned. This suggests it's either linked to your account, or tied to some extension or browser customization you're running.

Could you test on another machine, or on another browser - or even a private/incognito window - to see if the same behavior persists?

Also, could you confirm that you are going to Dashboard > Appearance, and scrolling down the page, and you reach the bottom after the first 20 alphabetical themes?

#9 Updated by Jessica Murray about 3 years ago

When I didn't initially see any flags, I changed the JS console settings in Chrome to "Verbose" under "All Levels" to see the error. I think you're right that it is an extension that is causing the problem. I still have to refresh when I open a new session on both PC and Mac, but not in incognito. I will try to figure out which extension is causing the problem, but it's probably not a common issue.

#10 Updated by Boone Gorges about 3 years ago

Thanks for investigating, Jessica!

Also available in: Atom PDF