Project

General

Profile

Bug #10164

A few oddities related to a cross-posted forum post

Added by Matt Gold about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Forums
Target version:
Start date:
2018-08-16
Due date:
% Done:

0%

Estimated time:

Description

Today I posted something to one of my groups and set it up to post to a bunch of other groups, as well.

I've noticed a few strange things about the post:

1. In "My Commons," the feed appears to use the body of the post instead of its title

2. On all of the forums on which it was posted, there is no title displayed on the forum post itself

3. The forum title does appear as expected in the list of forum topics

I believe (but I'm not certain) that I posted using the web interface on this forum -- https://commons.gc.cuny.edu/groups/mals-digital-humanities-track/forum/topic/job-research-computing-instruction-lead-columbia-5/

Screenshots attached

History

#1 Updated by Boone Gorges about 1 year ago

The issue with post content - rather than post title - being used to construct the strings you see in the activity stream, was fixed in bp-multiple-forum-post a few months ago but never merged to the Commons. https://github.com/cuny-academic-commons/bp-multiple-forum-post/commit/4608641b88b47a81389137ed38d5813407aff109 I've backported to the Commons in https://github.com/cuny-academic-commons/cac/commit/11464f198420b1bec0d2ebba2e3ca387c5c4ff0a

Your observation in 2 isn't quite right - forum thread titles don't appear in the interface for any topics, regardless of whether they were involved in crossposting. This dates to https://github.com/cuny-academic-commons/cac/commit/063d77d03f3e96ecaa13f8176bc00bbc5f316e05, which was part of #3177. It appears that the logic here was that the /forum/ page for a group does indeed have a duplicate header, but it didn't take into consideration the title on single topic pages. I've made some modifications to fix this. See screenshot.

#2 Updated by Matt Gold about 1 year ago

Thank you -- and interesting! So, for the last four years, individual topic pages haven't shown post titles?

#3 Updated by Boone Gorges about 1 year ago

Yes, unless something changed in the interim - like, maybe the upstream bbPress templates that we inherit used to show the title twice, but then they stopped at some point since then.

Also available in: Atom PDF