Project

General

Profile

Feature #10230

Reject login.cuny.edu registrations

Added by Boone Gorges 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority name:
High
Assignee:
-
Category name:
-
Target version:
Start date:
2018-08-27
Due date:
% Done:

0%

Estimated time:

Description

See https://redmine.gc.cuny.edu/issues/9979#note-7 and follow-up comments.

@login.cuny.edu email addresses appear to be used for logging into CUNYFirst and other CUNY-wide services, but they do NOT appear to be linked to real inboxes. This means that they should not be used for Commons registration, since user accounts need real email addresses. Otherwise, they can't be activated.

So, two tasks:

1. We should confirm that the above is correct. Of the 117 Commons registrations using login.cuny.edu, 16 of them have been activated at some point. This means that there must be something more complicated going on. Maybe @login.cuny.edu forwards to a campus email in some cases? (Didn't work for me, but it's a complicated system.) Or maybe these 16 were manually confirmed?

2. If it's true that there's no inbox, we should have some logic during registration that detects login.cuny.edu addresses being entered, and lets users know that it's not valid for registration. I guess this could take the form of a client-side check that will add a little notice under the email box with an error message (text tbd). We could then prevent the form from being submitted.

Screenshot_2018-08-29_20-05-44.png (17.3 KB) Screenshot_2018-08-29_20-05-44.png Boone Gorges, 2018-08-29 04:06 PM

Related issues

Related to CUNY Academic Commons - Bug #9979: Reports of slow email activation emailsReporter Feedback2018-07-03

History

#1 Updated by Boone Gorges 8 months ago

  • Related to Bug #9979: Reports of slow email activation emails added

#2 Updated by Marilyn Weber 8 months ago

That is absolutely the case.
Here's a recent response I gave on Zendesk:

"I just wanted to add that although you have what looks like a CUNY email address, it is a quirk of CUNYFirst that the @login.cuny.edu addresses go nowhere. Once you register, you'll be assigned a @gradcenter.cuny.edu address which you can actually use. We fervently wish that the system was more straightforward but unfortunately it is not. "

#3 Updated by Marilyn Weber 8 months ago

  • Priority name changed from Normal to High

This is quickly becoming the bane of my existence. I've moved the priority up (but of course you can move it back, Boone!)

#4 Updated by Boone Gorges 8 months ago

  • Target version set to 1.13.8

Thanks, Marilyn. In the interest of getting something set up quickly, I'm going to implement what's in the following screenshot. If anyone has better suggestions in the next few hours, I can consider them, otherwise we can refine in future releases.

#6 Updated by Marilyn Weber 8 months ago

Looks great to me!

#7 Updated by Boone Gorges 8 months ago

  • Status changed from New to Resolved

Implemented in https://github.com/cuny-academic-commons/cac/commit/cfd1e6e2efa872381228b9443e2c9f199d2bc49d. Closing to clear the milestone. This will be in place later today.

#8 Updated by Matt Gold 8 months ago

thank you, Boone.

Also available in: Atom PDF