Project

General

Profile

Bug #10357

Invitation snafu

Added by Matt Gold over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
Onboarding
Target version:
-
Start date:
2018-09-20
Due date:
% Done:

0%

Estimated time:

Description

I just tried to invite Sonja to our CAC team and subcommittee groups. When I got to step 3 -- review and submit -- I clicked "submit" and saw the button display a moving wheel, as if the request was being processed. But then it stopped and I was not taken to the checkmark/you're done! confirmation page. I am unclear on whether the invites actually went through

History

#1 Updated by Boone Gorges over 3 years ago

  • Status changed from Assigned to Reporter Feedback

I don't see any invitations created today by your user, so it must not have gone through. You can always check to see whether an invitation has been created by going to the "Invitations Sent" subsection of your Commons profile. https://commons.gc.cuny.edu/members/admin/invites/sent/

I've spent a few minutes looking through access logs for clues, but it a bit of a haystack. Do you recall what URL you were on when you launched the invitation modal? Were you looking at the Commons subcommittee group?

I'd suggest that you can try the invitations again, this time with your browser's JavaScript console open to the Network subtab (filtered to "XHR" if you want to reduce noise). You should see an AJAX request fired when you click 'Submit'; if it fails, let me know what the dev tools say (especially the request response and status code).

#2 Updated by Matt Gold over 3 years ago

I was on the CAC team group page. I will try again w/ JS console open

#3 Updated by Matt Gold over 3 years ago

Just tried again with the network console open. Everything worked as expected and the invitations appear to have gone through.

#4 Updated by Boone Gorges over 3 years ago

Thanks, Matt - glad it worked.

Based on your previous comment (thanks for that, btw), I see 403s in the logs:

/var/log/httpd/commons [1014]$ grep "2018:13:2" ssl_access.log | grep POST | grep "cac-comm" 
173.56.64.200 - - [20/Sep/2018:13:25:32 -0400] "POST /wp-json/caco/v1/invitation-event/ HTTP/1.1" 403 94 "https://commons.gc.cuny.edu/groups/cac-community-team-project-planning/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36" 45847
173.56.64.200 - - [20/Sep/2018:13:26:18 -0400] "POST /wp-json/caco/v1/invitation-event/ HTTP/1.1" 403 94 "https://commons.gc.cuny.edu/groups/cac-community-team-project-planning/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36" 46129

These request definitely should not be rejected as "unauthorized" for a logged-in user. It could be that there was some sort of cookie authentication error caused by network hiccups. Given that we haven't heard other reports of this, and don't have steps to reproduce, I'd suggest we can probably close out, with a mental note to circle back if this comes up again.

#5 Updated by Matt Gold over 3 years ago

  • Status changed from Reporter Feedback to Rejected

Okay. It is possible that my wifi was spotty, so let's proceed as you suggest. Thanks!

Also available in: Atom PDF