Project

General

Profile

Bug #111

More Privacy Options and BP Feed

Added by Matt Gold over 12 years ago. Updated about 12 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Upgrades
Target version:
-
Start date:
2009-12-04
Due date:
% Done:

0%

Estimated time:

Description

Hi Boone. Steve Brier's course blog, which is set to be visible only to blog members via "More Privacy Options," is showing up in the news feed.

History

#1 Updated by Boone Gorges over 12 years ago

Comments, or blog posts, or both? I think I already fixed the blog post issue.

#2 Updated by Matt Gold over 12 years ago

Comments, definitely. Not sure about blog posts, but I'm guessing no.

#3 Updated by Matt Gold over 12 years ago

I have just confirmed that a new post on a blog set to be viewable only to members has shown up in the sitewide feed, so it looks like it is both posts and comments.

#4 Updated by Boone Gorges over 12 years ago

  • Status changed from Assigned to Reporter Feedback

Fixed, through a few changes to BP core. I will document those changes on the Core Modifications Whiteboard in Basecamp.

#5 Updated by Boone Gorges over 12 years ago

Just realized that a change needed to be made to the Recent Blog Posts widget on the front page too. Have done so. Not a core modification because we've already customized the widget in bp-nelo/functions.php. See lines 120-126 for the modifications.

#6 Updated by Boone Gorges about 12 years ago

  • Status changed from Reporter Feedback to Resolved

Haven't heard back so I assume it's fixed. FYI I have written a plugin that will solve the problem definitively when we move to BP 1.2: http://wordpress.org/extend/plugins/bp-mpo-activity-filter/

Also available in: Atom PDF