Project

General

Profile

Bug #114

Group forum subscription

Added by Manfred Kuechler almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Group Forums
Target version:
-
Start date:
2009-12-05
Due date:
% Done:

0%

Estimated time:

Description

Just watch the video: http://screencast.com/t/MGUyNWJiNT
Conflicting message on whether or not I am subscribed. And I has not received any e-mail notification I suppose I am not.

History

#1 Updated by Matt Gold almost 10 years ago

  • Category name set to Group Forums
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

Thanks, Manfred. We'll look into this and update the ticket soon.

#2 Updated by Boone Gorges almost 10 years ago

  • Status changed from Assigned to Reporter Feedback

Thanks for the video, Manfred. The inconsistency you note is not a programming error but a description error. The message under "group forum subscription" on the home page of a group doesn't actually tell you whether you're subscribed to all discussions in the group but instead whether you will be subscribed automatically to any new discussions that are begun in the group. (In other words, that block of text corresponds to the settings at the bottom of this page http://commons.gc.cuny.edu/members/manfred/settings/notifications/.) The message on the topic page itself ("You are not subscribed to this topic") accurately reflects whether you will receive emails for that particular topic. I've changed the text on the main group page to be more accurate.

This issue reminds me that the interface needs to be improved. It would be nice to be able to see at a glance which topics you're subscribed to, without having to click on each individual topic title. I'll implement that soon.

#3 Updated by Manfred Kuechler almost 10 years ago

You are missing the point. My notification settings as to group subscriptions had been set for while to "yes" (the only thing that I changed today was notifications for wires; I am not even sure whether this stuck as I had changed it earlier and when I re-checked just now it was back to "no", so I tried again). I started the "Missing moodle" discussion on Wed night only (less than three days ago), so I should have been automatically subscribed to this new discussion. Or am I confused about what a "discussion" is? In Bb it would be called a "thread", but there do not seem to be any "threads" here. So, if "Missing Moodle" not a "discussion" than what is it? And how can I make certain that I am subscribed to whatever this is -- beyond going there after it has been created and click the subscribe button there?

Also, I don't see any link to this ticketing system on the AC site. The only way for me to get back was to find Matt's posting again and follow the link from there. Now, this may be done on purpose because there are pros and cons to making a ticketing system directly available to the end user. But sending "feedback/update" messages from a "no reply" e-mail address with no indication whatsoever how the user can respond is certainly not best help desk practice (ITIL). And pissing off users is not the way to build a clientele of "loyal customers".

#4 Updated by Matt Gold almost 10 years ago

  • Assignee changed from Boone Gorges to Matt Gold

Manfred, I think you're right that if one has subscribed to a group through notification settings, then one should be automatically subscribed to all discussions started there. So we'll look into this.

We haven't prominently displayed the issues site less because of the pros/cons of making our ticketing system open to the end user than to the requirement that users create a second login in order to use it. However, when users email the main cunycommons address with bug reports, I do create tickets for them. Anyway, I'll talk to others about the pros and cons of making the issues site more visible.

In the end, we might wind up making better use of our UserVoice site, which you can find via the gray "Feedback" button near the scroll bar. Right now, it just allows users to submit suggestions for new features, but I'd like to include a bug reporting system there, as well.

#5 Updated by Matt Gold almost 10 years ago

  • Status changed from Reporter Feedback to Resolved

Hi Manfred,

I cannot reproduce the behavior you reported. The database states that you are subscribed to the topic in question, and also that you are automatically subscribed to all new discussions in that forum. And the plugin is working properly for other members.

If you experience this issue again, please do not manually click the "subscribe" button but instead report the issue immediately so that troubleshooting can take place.

I'm closing this ticket for now but I will reopen it if you have further errors.

Thanks,

Matt

#6 Updated by Matt Gold almost 10 years ago

  • Status changed from Resolved to Reporter Feedback
  • Priority name changed from Normal to High

We've just had another report of a user having problems with subscriptions to forum posts, so I'm reopening the ticket and escalating its priority to High. Our developers will be taking a well-deserved day off tomorrow (we've been going non-stop in advance of the debut of the site at the CUNY IT conference), but we'll get back on this on Monday.

Thanks for your patience.

Best,

Matt

#7 Updated by Matt Gold almost 10 years ago

A quick update to a tangential point: I didn't have time before the conference to update the help page that you pointed to, but it has now been updated and it does include a link to the issues site. We need to work more on this page and on the documentation it provides, but it is a start. http://commons.gc.cuny.edu/help/

#8 Updated by Matt Gold almost 10 years ago

  • Status changed from Reporter Feedback to Resolved

During the process of troubleshooting this issue, we found a bug that was causing our automatic email subscription plugin to fail for some members of the group. We have now fixed this problem and we have confirmed that everything is working correctly.

I just put up a new post in the CAT forum; you should have received notification of this via email. If you didn't, or if you experience any other subscription problems, please do not manually click the "subscribe" button but instead report the issue immediately so that troubleshooting can take place.

Thank you very much for reporting this issue. I am closing this ticket, but I will reopen it if the issue arises again.

Also available in: Atom PDF