Project

General

Profile

Support #12137

media player problem

Added by Marilyn Weber almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
WordPress Themes
Target version:
Start date:
2019-11-22
Due date:
% Done:

0%

Estimated time:

Description

John Paul Hill write via Zendesk:

I'm writing about the Office of Career Planning & Professional Development's website. (https://careerplan.commons.gc.cuny.edu/)

We're having an issue with the appearance of our media player. We use the plugin Blubrry PowerPress to publish our podcast, Alumni Aloud. Recently we've noticed that the media player loads properly initially but then automatically reloads to a different display. We're less concerned with the way the forced reload looks than we are with the fact that the media player covers the line of text above it.

I've included a few screenshots to illustrate the issue. On our podcast pages, we use the PowerPress code [powerpress] to control where the media player shows up on the page. However, I don't think that the issue is in the PowerPress plugin because the display issue also shows up on our transcript pages. On our transcript pages, we use [audio src=" "] to insert the media player, and we have the same problem.

I'm hoping that the media player style is getting overwritten by something on our website's style sheet. Our child theme was copied from the Library's old website.

Later he added:
The screenshots that I included in the original request were of the following two webpages on our site:
https://careerplan.commons.gc.cuny.edu/blog/alumni-aloud-episode-41
https://careerplan.commons.gc.cuny.edu/blog/alumni-aloud-episode-01-transcript

cppd 1 forced reload.jpg (142 KB) cppd 1 forced reload.jpg Marilyn Weber, 2019-11-23 09:25 AM
cppd 1 intended.jpg (136 KB) cppd 1 intended.jpg Marilyn Weber, 2019-11-23 09:25 AM
cppd 1.jpg (135 KB) cppd 1.jpg Marilyn Weber, 2019-11-23 09:25 AM

History

#1 Updated by Boone Gorges almost 2 years ago

  • Status changed from New to Reporter Feedback

Marilyn, are you able to share the screenshots?

#3 Updated by Boone Gorges almost 2 years ago

  • Category name set to WordPress Themes
  • Target version set to Not tracked

Thanks for sharing these.

The user is correct that the PowerPress plugin is responsible for the style "flash". After the audio player is loaded by WP, PowerPress replaces it with its own player - apparently, it does this for [powerpress] as well as [audio] shortcodes.

The text overlap is being caused by an overly general custom CSS declaration. See https://careerplan.commons.gc.cuny.edu/wp-admin/admin.php?page=themify#styling-custom_css. About two-thirds of the way down the list, under /* CENTER MAIN NAVIGATION MENU */, is a declaration div { position: relative; }. Once commented out (as I've done for you) the media player appears as expected. I'm unsure whether this affects the "center main navigation menu" - if there's a difference, I didn't spot it - but if the style needs to be reinstated, it should be done with a selector much more specific than div.

#4 Updated by Marilyn Weber almost 2 years ago

  • Status changed from Reporter Feedback to Resolved

Another where the admin fixed it following your instructions. Resolved.

Also available in: Atom PDF