Project

General

Profile

Bug #12143

Order drop-down not changing

Added by Colin McDonald about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
-
Target version:
Start date:
2019-11-24
Due date:
% Done:

0%

Estimated time:

Description

Moving this from the Commons team forum testing thread, I'm having trouble using the ordering drop-down in the new Courses tab. I'm on a Mac, and while it worked fine in Firefox, in Chrome (77.0.3865.120) and Safari (Version 13.0.3) I'm having trouble getting a new selection in the drop-down to register and load. The URLs for a new selections don't seem to load. See the screen recordings attached.

order-full-screen.mov (26.6 MB) order-full-screen.mov chrome screen recording Colin McDonald, 2019-11-25 11:37 AM
order-safari.mov (101 MB) order-safari.mov safari screen recording Colin McDonald, 2019-11-25 12:08 PM

History

#1 Updated by Boone Gorges about 2 years ago

  • Status changed from New to Testing Required

Thanks for the detailed report and the videos. I was able to reproduce when testing on Mac browsers. It turns out that they process certain JS events in a different order than other browsers - or it could be that certain browsers or computers are slow enough to cause an accidentally helpful race condition in other systems. I've corrected the logic in https://github.com/cuny-academic-commons/cac/commit/8551bebc166526c68677e5d585f64990006770fe and this should be working now.

#2 Updated by Colin McDonald about 2 years ago

  • Status changed from Testing Required to Resolved

Tested on my end, looks good! Marking resolved.

Also available in: Atom PDF