Project

General

Profile

Support #12157

Courses slideshow access/planning

Added by Colin McDonald about 2 years ago. Updated 9 months ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Courses
Target version:
Start date:
2019-12-01
Due date:
% Done:

0%

Estimated time:

Description

Hey Boone, I think my Commons account (colinmcd) may need access to these links you mentioned on the production site. Or I need access on the dev site, which might not matter once the release happens. I realized I wasn't quite sure where these links were live:

https://commons.gc.cuny.edu/wp-admin/edit.php?post_type=cac_course (find the courses you want to feature)
https://commons.gc.cuny.edu/wp-admin/edit.php?post_type=cac_course&page=cac-courses-featured (enter the IDs of those courses)

If you just want to make this course live when we release, I can confirm that this has a featured image and we have permission to use it:
https://sochiphop.commons.gc.cuny.edu/

I am pretty sure that we can use this course of Krysia's as well, and it has a featured image:
https://eng110michael.commons.gc.cuny.edu/

I will have other courses with permission that I can add myself by Wednesday, if that works. By the way, what is the "ID" of a course, specifically? Let me know what else I can do here, thanks.

History

#1 Updated by Colin McDonald about 2 years ago

  • Tracker changed from Bug to Support

#2 Updated by Boone Gorges about 2 years ago

  • Status changed from New to Reporter Feedback

I've granted colinmcd the Editor role on the dev and production sites, so you should be able to visit https://commons.gc.cuny.edu/wp-admin/edit.php?post_type=cac_course

The ID of a course is the unique numeric ID assigned by WP to the course "post" object. So the ID of the Sociology of Hip-Hop course https://commons.gc.cuny.edu/wp-admin/post.php?post=77510&action=edit is 77510.

https://commons.gc.cuny.edu/wp-admin/edit.php?post_type=cac_course&page=cac-courses-featured is not yet accessible on production but you should now be able to visit it on cdev.

At the time of release, I'll manually set Sociology of Hip-Hop as a featured course. Before that time, the post https://commons.gc.cuny.edu/wp-admin/post.php?post=77510&action=edit should have a Featured Image - see the right-hand sidebar for where this should be set. It is NOT yet set. I visited the site https://sochiphop.commons.gc.cuny.edu/ but was not sure which image should be used. Could you either give me the URL of the specific image, or set it yourself at https://commons.gc.cuny.edu/wp-admin/post.php?post=77510&action=edit?

#3 Updated by Colin McDonald about 2 years ago

Thanks Boone, I was able to access the Courses backend page on dev and production, but not the cac-courses-featured on dev for whatever reason. Maybe I'll just wait on that one for production.

I set the featured image for the Hip-Hop course, so we're good to go there. I'll post on this ticket again if I have others for which we get permission and a featured image set up before launch.

#4 Updated by Boone Gorges about 2 years ago

  • Category name set to Courses

Oops, there was a mismatch between the capability check for accessing Dashboard > Courses and the new Featured subtab. This should be fixed in https://github.com/cuny-academic-commons/cac-courses/commit/319a2aaadb05c0fa02d3a9a180b3d699e5f9450e and can be tested on the dev site.

#5 Updated by Colin McDonald about 2 years ago

For some reason my dev password doesn't seem to be working, if you might know why or can send me a reminder. But for now, the three courses to go live with in the slideshow (was going to add them in dev myself) are 77510, 77588 and 76791. They all have featured images. Thanks!

#6 Updated by Boone Gorges about 2 years ago

I had to hijack cdev for a few hours to address #12180, which is why you were unable to access. I'll add the featured courses listed above after the launch.

#7 Updated by Boone Gorges about 2 years ago

  • Status changed from Reporter Feedback to Resolved

#8 Updated by Colin McDonald 9 months ago

I went back to this ticket while thinking about #14180 and what we'll build to show featured content on the new homepage. But it seems that I can't access the link below to change the featured courses. Is this an access issue with my account, or something else? I'll admit I haven't checked this link in months, if that matters:

https://commons.gc.cuny.edu/wp-admin/edit.php?post_type=cac_course&page=cac-courses-featured

#9 Updated by Boone Gorges 9 months ago

Colin, you lost access because you don't have a role on the main site. I'm unsure why that is. I've made you Editor, so you should now be able to access.

#10 Updated by Colin McDonald 9 months ago

Yep, that was it. All set now, thanks!

Also available in: Atom PDF