Project

General

Profile

Actions

Bug #1230

closed

Access to blogs after release

Added by scott voth almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
-
Start date:
2011-10-12
Due date:
% Done:

0%

Estimated time:

Description

Hi - I've noticed that I can't get into some blogs after release. For example: DHI - http://cunydhi.commons.gc.cuny.edu/ Codex - http://codex.commons.gc.cuny.edu/ GSLIS - http://qcgslis.commons.gc.cuny.edu/
But I have been able to get into others. for example - http://latinofacultyinitiativecuny.commons.gc.cuny.edu/

Anyone else seeing this problem?


Related issues

Has duplicate CUNY Academic Commons - Bug #1231: Inaccessible Site on the CommonsDuplicate2011-10-12

Actions
Actions #1

Updated by local admin almost 11 years ago

  • Priority name changed from Normal to High

Confirmed. Fails for me as well.

The only error apparent on the web server log refers to a plugin, WikiInc.php. It's complaining about unexpected $end variable on line 168.

Actions #2

Updated by local admin almost 11 years ago

Here's the error message:

[Wed Oct 12 22:45:58 2011] [error] [client 72.229.162.211] PHP Parse error: syntax error, unexpected $end in /var/www/html/wp-content/plugins/WikiInc.php on line 168, referer: http://redmine.gc.cuny.edu/issues/1230

Actions #3

Updated by Boone Gorges almost 11 years ago

  • Status changed from New to Assigned
  • Assignee set to local admin

The problem was indeed WikiInc.php. The author used a short delimiter https://github.com/castiron/cac/commit/a9235088d22b9e9f3b866ad3326182e9d60dfd32 and did a hotfix on the live site.

There may be other plugins, now and in the future, that make the same mistake. For that reason, it's probably a good idea to configure PHP to be more forgiving about this. André, can you help with that? Here's a guide I found: http://www.cyberciti.biz/faq/php-allow-short_open_tag/

Leaving the ticket open until the change has been made to our PHP config.

Actions #4

Updated by Sarah Morgano almost 11 years ago

One of our members also just reported that she cannot access two of her blogs. The sites won't even load up. (See: http://commons.gc.cuny.edu/groups/wordpress-help/forum/topic/cant-view-my-blogs/)

At this point, what should be our response to members who report this problem?

Best,
Sarah

Actions #5

Updated by Boone Gorges almost 11 years ago

What are the URLs, please?

Actions #6

Updated by local admin almost 11 years ago

Boone Gorges wrote:

What are the URLs, please?

Boone, I followed the cookie crumb trail from the help forum post to the user's page, then to her list of blogs. It's the same issue:

[Thu Oct 13 12:13:15 2011] [error] [client 72.229.162.211] PHP Parse error: syntax error, unexpected $end in /var/www/html/wp-content/plugins/front-page-category/front-page-category.php on line 91, referer: http://commons.gc.cuny.edu/members/giulia/blogs/

I'm changing that PHP setting as requested now...

Actions #7

Updated by local admin almost 11 years ago

Ok, setting short_open_tag: On seems to have fixed it.

Please note that this practice is deprecated! There may be issues with processing XML and stuff [ http://www.php.net/manual/en/ini.core.php#ini.short-open-tag].

Actions #8

Updated by local admin almost 11 years ago

  • Category name changed from WordPress (misc) to 44
  • Status changed from Assigned to Reporter Feedback
  • Priority name changed from High to Normal
Actions #9

Updated by Boone Gorges almost 11 years ago

Ok, setting short_open_tag: On seems to have fixed it.

Awesome, thanks for making this change, André!

I know the practice is deprecated, but the problem occurs in some third-party plugins that we're using, and I would rather not have to reapply a patch to them every time they are updated. Glad the blogs have come back to life :)

Actions #10

Updated by local admin almost 11 years ago

I would rather not have to reapply a patch to them every time they are updated.

Understood and agreed.

Glad the blogs have come back to life :)

Yep. Should we consider the issue resolved then?

Actions #11

Updated by Boone Gorges almost 11 years ago

  • Status changed from Reporter Feedback to Resolved

Should we consider the issue resolved then?

Boo ya!

Actions #12

Updated by Sarah Morgano almost 11 years ago

Terrific, I can see her blogs now! I'll let her know everything has been restored.

Actions

Also available in: Atom PDF