Project

General

Profile

Bug #12671

Creative Commons License Not Available With Block Editor

Added by scott voth over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2020-04-17
Due date:
% Done:

0%

Estimated time:

Description

When creating a page or post using the Block Editor, there is no ability to choose a creative commons license, and no license appears. If you then switch to Classic editor, the license appears. When you switch back to Block Editor, it is still displayed.

I think the Block Editor should show the license options.

John DeLooper reported that when he changed from Classic to Block Editor, the license stopped displaying - but I have not been able to reproduce this. His site is https://lehmanoer.commons.gc.cuny.edu/

license-gutenberg.png (10.2 KB) license-gutenberg.png Raymond Hoh, 2020-04-20 01:44 PM

History

#1 Updated by Raymond Hoh over 1 year ago

  • Category name changed from WordPress (misc) to WordPress Plugins
  • Status changed from New to Assigned
  • Target version set to 1.16.10

Thanks Scott. Looking into how hard it would be to integrate the license chooser into the Block Editor.

#2 Updated by Raymond Hoh over 1 year ago

I've added support for the Block Editor - https://github.com/cuny-academic-commons/cac/commit/1c5d29edc99ae287685e6df1f59142cc98f7c702

This will be available for the next maintenance release. This is what it looks like:

#3 Updated by scott voth over 1 year ago

Awesome Ray! Thanks!

#4 Updated by Boone Gorges over 1 year ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF