Project

General

Profile

Actions

Bug #1344

closed

Activity Feed Items not Appearing in Group

Added by Matt Gold almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2011-11-13
Due date:
% Done:

0%

Estimated time:

Description

I received an email notification for a group activity item, but when I click on the link in the email, I don't see the item in question. And when I click on the home page of the group, I see it there, either.

Email to follow.

Actions #1

Updated by Boone Gorges almost 11 years ago

The activity item is there: http://commons.gc.cuny.edu/members/Sarah_Morgano/activity/58310/

The problem is that Scott replied to the activity item, rather than to the Doc itself. This isn't how it should work; the Reply button on BP Docs activity items should go to the Doc comment area itself. See https://github.com/boonebgorges/buddypress-docs/issues/150

Actions #2

Updated by Boone Gorges almost 11 years ago

  • Status changed from Assigned to Resolved
  • Target version changed from 1.2.5 to 1.3

I've made the basic change to BuddyPress Docs: https://github.com/boonebgorges/buddypress-docs/issues/150

We have some further modifications on the Commons that make these links point directly to the comments section of forum posts. We don't currently have anything comparable for blog posts (or BP Docs, which are a kind of blog post). I will work on this, but it's a separate feature request, so I'm going to open a different ticket for it: #1346

The fix that I've just put into BuddyPress Docs depends on a filter introduced in BuddyPress 1.5. As a result, it won't work with BP 1.2.x. To make it compatible with BP 1.2.x would take a bunch of hacking; since Commons 1.3 will be along fairly soon, and since this is an edge case issue, I'm bumping the target version to 1.3.

Actions

Also available in: Atom PDF