Project

General

Profile

Bug #13497

Remove Elemental theme cache files

Added by Raymond Hoh about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Internal Tools and Workflow
Target version:
Start date:
2020-10-23
Due date:
% Done:

0%

Estimated time:

Description

I was upgrading my version of Git today on Windows and I can't seem to use git checkout because Windows doesn't like the following files that end with a period in their filename:

  • https://github.com/cuny-academic-commons/cac/blob/master/wp-content/themes/elemental/tools/cache/external_17176b7f92412c49d64df5d67e23a6e4.
  • https://github.com/cuny-academic-commons/cac/blob/master/wp-content/themes/elemental/tools/cache/external_32d44ec299c490da743687391241b0d7.
  • https://github.com/cuny-academic-commons/cac/blob/master/wp-content/themes/elemental/tools/cache/external_46b50796b000b903a9ffb44d9d67ea1f.
  • https://github.com/cuny-academic-commons/cac/blob/master/wp-content/themes/elemental/tools/cache/external_b31ef4984200da9cd8c5863c7e989b43.
  • https://github.com/cuny-academic-commons/cac/blob/master/wp-content/themes/elemental/tools/cache/external_c6e2b876184235b9ee060f78dd8a738f.

The older version of Git on Windows simply pulled down those files and ignored the period, but the later versions of Git on Windows throws an "invalid path" error.

I'm going to remove all Elemental cache files in a subsequent commit since we have ignored these files since commit 4d8cd6e4. Then, I'll see if I can checkout afterwards without resorting to setting git config core.protectNTFS to false.

Boone, this is just a FYI.

History

#1 Updated by Raymond Hoh about 1 year ago

  • Status changed from New to Staged for Production Release

I've removed the Elemental theme cache files in https://github.com/cuny-academic-commons/cac/commit/1dd243b4afa913f536751b4989328ab23a4d4f27.

Confirmed that this addressed the problem for me.

#2 Updated by Boone Gorges about 1 year ago

Thanks!

#3 Updated by Boone Gorges 12 months ago

  • Target version changed from 1.17.6 to 1.17.7

#4 Updated by Boone Gorges 12 months ago

  • Target version changed from 1.17.7 to 1.17.6

#5 Updated by Boone Gorges 12 months ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF